Bug 61625 - File Editor used in BeanInfo behaves strangely under all LAFs with impact on CSVDataSet, JSR223, BSF, Beanshell Element
Summary: File Editor used in BeanInfo behaves strangely under all LAFs with impact on ...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-17 17:51 UTC by Philippe Mouawad
Modified: 2018-02-22 19:59 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-10-17 17:51:47 UTC
Since the Browse Button has been added to CSV Data Set in Bug 61039 , there is a very annoying regression when using Windows LAF:

- Select a file using Browse
- Save plan => OK
- Edit the path without using Browse
- Save => KO , field is silently reset to previous value
In order to make it work you need to select Edit in combox box => Very counter intuitive



Another more impacting regression:
- Select a file using Browse
- Save plan => OK
- No use Edit in Select Box 
- Copy / Paste the exact path you get from File Properties in Windows
- The file is not found when JMeter runs

I think we should release a bugfix version including a fix to all components impacted by Browse addition.
Comment 1 Antonio Gomes Rodrigues 2017-10-18 08:04:24 UTC
Hi,

I think it's a problem of focus

Because if after the modification of the field, we press enter the proble disappear

I will check the source code asap

Antonio
Comment 2 Philippe Mouawad 2017-10-18 16:05:47 UTC
(In reply to Philippe Mouawad from comment #0)
> Since the Browse Button has been added to CSV Data Set in Bug 61039 , there
> is a very annoying regression when using Windows LAF:
> 
> - Select a file using Browse
> - Save plan => OK
> - Edit the path without using Browse
> - Save => KO , field is silently reset to previous value
> In order to make it work you need to select Edit in combox box => Very
> counter intuitive
> 
> 
> 
> Another more impacting regression:
> - Select a file using Browse
> - Save plan => OK
> - No use Edit in Select Box 
> - Copy / Paste the exact path you get from File Properties in Windows
> - The file is not found when JMeter runs



After further analysis, it appears that a nasty characters was being inserted before the full path, it was invisible in JMeter UI but this explains why file was not found. So this part of bug report is not a problem.
> 
> I think we should release a bugfix version including a fix to all components
> impacted by Browse addition.
Comment 3 Philippe Mouawad 2017-11-11 17:29:26 UTC
Scenario :
- Select a file using Browse
- Save plan => OK
- Edit the path directly in the Filename field without using Browse
- Save => KO , field is silently reset to previous value
In order to make it work you need to select Edit in combox box => Very counter intuitive


If you just leave the file (focusLost) the value is saved.

It appears this is a very impacting regression.
Comment 4 Philippe Mouawad 2017-11-11 17:36:40 UTC
Author: pmouawad
Date: Sat Nov 11 17:35:16 2017
New Revision: 1814963

URL: http://svn.apache.org/viewvc?rev=1814963&view=rev
Log:
Bug 61625 - File Editor used in BeanInfo behaves strangely under all LAFs with impact on CSVDataSet, JSR223, BSF, Beanshell Element
Bugzilla Id: 61625

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/testbeans/gui/FileEditor.java
    jmeter/trunk/xdocs/changes.xml
Comment 5 Benny van Wijngaarden 2018-02-22 16:01:09 UTC
Just started using version 4.0. 
This problem is not solved there.

Situation:
- Open a file with a CSV Data Set Config element
- Edit the path to contain e.g. testdata/myfile.csv
- Pressing Save will change the / into \

On Windows this still works, but when running the script via Jenkins this might cause problems (not confirmed yet, but expect them)
Comment 6 Philippe Mouawad 2018-02-22 19:59:46 UTC
(In reply to Benny van Wijngaarden from comment #5)
> Just started using version 4.0. 
> This problem is not solved there.
> 
> Situation:
> - Open a file with a CSV Data Set Config element
> - Edit the path to contain e.g. testdata/myfile.csv
> - Pressing Save will change the / into \
> 
> On Windows this still works, but when running the script via Jenkins this
> might cause problems (not confirmed yet, but expect them)

Please open another issue marked as affecting 4.0 as the bug reported here is really fixed.

Note that I don't reproduce your scenario on Mac OSX with Darcula LAF.

When opening a new bug, please indicate:
- OS type and version
- LAF used
- Java version
Thanks
Regards