Bug 61661 - Avoid startup/shutdown problems due to 3rd party Thread Listener plugins throwing RuntimeException
Summary: Avoid startup/shutdown problems due to 3rd party Thread Listener plugins thro...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.3
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 61744 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-24 15:45 UTC by utkarshs
Modified: 2017-11-11 12:57 UTC (History)
2 users (show)



Attachments
Jmeter test running after sample executed (68.86 KB, image/png)
2017-10-24 15:45 UTC, utkarshs
Details
Console (19.51 KB, image/png)
2017-10-24 15:47 UTC, utkarshs
Details
Thread Group Configuration (62.87 KB, image/png)
2017-10-24 15:47 UTC, utkarshs
Details
Thread Dump (5.08 KB, text/plain)
2017-10-25 07:46 UTC, utkarshs
Details
Jmeter Log (8.68 KB, text/plain)
2017-10-25 07:46 UTC, utkarshs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description utkarshs 2017-10-24 15:45:57 UTC
Created attachment 35455 [details]
Jmeter test running after sample executed

I'm using Jmeter to run a Selenium WebDriver test, everything seems ok, I only have 1 thread configured with 1 sec ramp up and 1 loop count, however after the webdriver execution is completed, Jmeter does not stops the overall test execution and keeps on executing the test for infinity, I'm not sure why is that happening, I'm using chromedriver and all the configuration I have done is as per jmeter documentation, I have also added WDS.sampleResult.sampleEnd() command at the end of my script. The execution does not even stops if I click Stop or Shutdown buttons explicitly. Please refer screenshots attached.
Comment 1 utkarshs 2017-10-24 15:47:01 UTC
Created attachment 35456 [details]
Console
Comment 2 utkarshs 2017-10-24 15:47:27 UTC
Created attachment 35457 [details]
Thread Group Configuration
Comment 3 Philippe Mouawad 2017-10-24 21:34:10 UTC
can you attach jmeter.log not a screenshot ?

And also when it happens use Help > Thread dump and provide the generated file

Thanks
Comment 4 utkarshs 2017-10-25 07:46:25 UTC
Created attachment 35458 [details]
Thread Dump
Comment 5 utkarshs 2017-10-25 07:46:54 UTC
Created attachment 35459 [details]
Jmeter Log
Comment 6 utkarshs 2017-10-25 07:47:22 UTC
(In reply to Philippe Mouawad from comment #3)
> can you attach jmeter.log not a screenshot ?
> 
> And also when it happens use Help > Thread dump and provide the generated
> file
> 
> Thanks

Sure, I have attached both the files with the ticket, please have a look
Comment 7 Philippe Mouawad 2017-10-25 07:59:26 UTC
Thanks for further information.
This is a 3rd party plugin and a configuration issue on your side.

See answer:

- https://stackoverflow.com/a/46926974/460802
Comment 8 Philippe Mouawad 2017-10-25 13:00:47 UTC
Author: pmouawad
Date: Wed Oct 25 13:00:24 2017
New Revision: 1813277

URL: http://svn.apache.org/viewvc?rev=1813277&view=rev
Log:
Bug 61661 - Avoid startup/shutdown problems due to 3rd party Thread Listener plugins throwing RuntimeException
Bugzilla Id: 61661

Added:
    jmeter/trunk/test/src/org/apache/jmeter/threads/TestJMeterThread.java   (with props)
Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
    jmeter/trunk/xdocs/changes.xml
Comment 9 Philippe Mouawad 2017-11-11 12:57:05 UTC
*** Bug 61744 has been marked as a duplicate of this bug. ***