Bug 61698 - Test Action: It stop is selected, samplers following Test Action can run
Summary: Test Action: It stop is selected, samplers following Test Action can run
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.3
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-30 21:32 UTC by Philippe Mouawad
Modified: 2017-10-30 21:34 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-10-30 21:32:12 UTC
Report on user mailing list:
--------------------------------------------------------------------------------------------------
When adding Test Action
<http://jmeter.apache.org/usermanual/component_reference.html#Test_Action> with
Stop/Stop Now action

You have Target options: All Threads/Current Thread

When choosing Current Thread in a multiple threads environment it stops and
don't continue further this Sampler

The problem is that when choosing *All Threads* Some threads execute other
sampler after than Test Action

It's very confusing, because I expect All Threads option to be more strict
than just Current Thread

In code I saw that in Current Threads it also stop current threads
context.getThread().stop();and in All Threads option it doesn't.

Is it a bug or a feature (adding grace period of stopping)?

For example Test Plan:

   - Thread Group (5 Threads)
      - Sampler1
      - Test Action Target: All Threads, Action Stop/Stop Now
      - Sampler2

Sampler 2 is execute only when Target: All Threads and not when Target:
Current Thread

Note: Also choosing Action Go to next loop iteration (Target field is
disabled) prevent Sampler2 to be executed

--------------------------------------------------------------------------------------------------
Comment 1 Philippe Mouawad 2017-10-30 21:34:15 UTC
Author: pmouawad
Date: Mon Oct 30 21:33:54 2017
New Revision: 1813832

URL: http://svn.apache.org/viewvc?rev=1813832&view=rev
Log:
Bug 61698 - Test Action: It stop is selected, samplers following Test Action can run
Bugzilla Id: 61698

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/sampler/TestAction.java
    jmeter/trunk/xdocs/changes.xml