Bug 61772 - Fail to validate new java version(9.0.1) when launch by jmeter.bat
Summary: Fail to validate new java version(9.0.1) when launch by jmeter.bat
Status: RESOLVED DUPLICATE of bug 61529
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.3
Hardware: PC All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-17 03:15 UTC by yang lei
Modified: 2017-11-17 16:02 UTC (History)
0 users



Attachments
error message in command line (5.62 KB, image/png)
2017-11-17 03:15 UTC, yang lei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yang lei 2017-11-17 03:15:07 UTC
Created attachment 35533 [details]
error message in command line

1. Install latest(currently Nov 2017) java sdk(9.0.1).
2. Download apache-jmeter-3.3.zip, unzip, run bin\jmeter.bat, error message:
  Error: Java version -- 9.0.1 -- is too low to run JMeter. Needs a Java version 
  greater than or equal to 1.8.0
  errorlevel=3
3. If run ApacheJMeter.jar directly, success.
Comment 1 Antonio Gomes Rodrigues 2017-11-17 07:55:30 UTC
Hi,

JMeter 3.3 is not compatible with Java 9

try nighty build https://builds.apache.org/job/JMeter-trunk/lastSuccessfulBuild/artifact/trunk/dist/

Antonio
Comment 2 Felix Schumacher 2017-11-17 16:02:03 UTC

*** This bug has been marked as a duplicate of bug 61529 ***