Bug 61842 - Saving with no changes causes a save and duplicate, identical backup file
Summary: Saving with no changes causes a save and duplicate, identical backup file
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-01 16:59 UTC by Graham Russell
Modified: 2017-12-09 17:37 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Russell 2017-12-01 16:59:05 UTC
Steps to reproduce:
1. Open any test plan
2. Hit save n times
3. n backups are made

This is pretty bad because a useful backup could easily drop off the list, especially for people who have a habit of pressing ctrl+s multiple times in a row.

Tested on current trunk with ant run_gui
Comment 1 Philippe Mouawad 2017-12-09 17:37:25 UTC
Author: pmouawad
Date: Sat Dec  9 17:36:56 2017
New Revision: 1817638

URL: http://svn.apache.org/viewvc?rev=1817638&view=rev
Log:
Bug 61842 - Saving with no changes causes a save and duplicate, identical backup file
Bugzilla Id: 61842

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/Save.java
    jmeter/trunk/xdocs/changes.xml