Bug 61846 - Scoped Assertion should follow same order of evaluation as Post Processors
Summary: Scoped Assertion should follow same order of evaluation as Post Processors
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.3
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 61815 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-01 21:21 UTC by Philippe Mouawad
Modified: 2018-01-06 21:41 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-12-01 21:21:19 UTC
When you have components at different levels:
- Pre and Post Processors are processed from OUTER to INNER
- Assertions are processed from INNER to OUTER
Comment 1 Philippe Mouawad 2017-12-01 21:50:33 UTC
Author: pmouawad
Date: Fri Dec  1 21:43:54 2017
New Revision: 1816914

URL: http://svn.apache.org/viewvc?rev=1816914&view=rev
Log:
Bug 61846 - Scoped Assertion should follow same order of evaluation as Post Processors
Bugzilla Id: 61846

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/TestCompiler.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2017-12-01 22:04:47 UTC
Author: pmouawad
Date: Fri Dec  1 22:04:25 2017
New Revision: 1816917

URL: http://svn.apache.org/viewvc?rev=1816917&view=rev
Log:
Bug 61846 - Scoped Assertion should follow same order of evaluation as Post Processors
Update XML test results
Bugzilla Id: 61846

Modified:
    jmeter/trunk/bin/testfiles/TestKeepAlive.xml
Comment 3 Philippe Mouawad 2017-12-01 22:21:16 UTC
Author: pmouawad
Date: Fri Dec  1 22:20:25 2017
New Revision: 1816923

URL: http://svn.apache.org/viewvc?rev=1816923&view=rev
Log:
Bug 61846 - Scoped Assertion should follow same order of evaluation as Post Processors
Update XML test results
Bugzilla Id: 61846

Modified:
    jmeter/trunk/bin/testfiles/ResponseDecompression.xml
    jmeter/trunk/bin/testfiles/TestHeaderManager.xml
Comment 4 Philippe Mouawad 2018-01-06 21:41:12 UTC
*** Bug 61815 has been marked as a duplicate of this bug. ***