Bug 61866 - Compression breaks with JDK update 1.8.0_151
Summary: Compression breaks with JDK update 1.8.0_151
Status: RESOLVED DUPLICATE of bug 61660
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 7.0.82
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-06 15:33 UTC by Maarten van Hulsentop
Modified: 2017-12-06 17:01 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten van Hulsentop 2017-12-06 15:33:04 UTC
When Tomcat 7.0.82 has compression enabled and is combined with jdk 1.8.0_151 (latest update) some responses are not decodeable.

Reproduction scenario;
- Use latest Tomcat 7, 7.0.82
- Use latest JDK 1.8.0_151
- Add  compression="on" to the HTTP connector
- (add a user to enter the manager application)
- Go to the URL http://localhost:8080/manager/html and enter the username/password
- The response will yield a "ERR_CONTENT_DECODING_FAILED" 

This does not happen when using an older JDK. In that light, i am not sure if this is JDK related or Tomcat. 
It does not happen for all pages (the examples and documentation on the same server seem to be working fine), manager application is fine.

Tested this on windows 10.
Comment 1 Maarten van Hulsentop 2017-12-06 15:43:35 UTC
Not reproducable with 8.0.47 and above
Comment 2 Mark Thomas 2017-12-06 17:01:24 UTC

*** This bug has been marked as a duplicate of bug 61660 ***