Bug 61937 - XSSFSheetXMLHandler doesn't document that it doesn't generate events for empty cells
Summary: XSSFSheetXMLHandler doesn't document that it doesn't generate events for empt...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-29 18:59 UTC by Geoff Baskwill
Modified: 2018-01-01 15:45 UTC (History)
0 users



Attachments
Documentation patch (1.05 KB, patch)
2017-12-29 18:59 UTC, Geoff Baskwill
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Baskwill 2017-12-29 18:59:06 UTC
Created attachment 35631 [details]
Documentation patch

The resolution for 57775 states that XSSFSheetXMLHandler doesn't generate events for empty cells as "by design, it returns only the cells physically present in the file". It seems that more specifically it returns only the cells with values in the file, as '<c>' elements that are physically present in the file but lack child elements will not result in cell events.

Rather than attempting to change the asserted design intent, the attached patch strives to make the intent and the mechanism for dealing with empty cells / rows more obvious to consumers by adding some documentation to the interface.

Related: https://bz.apache.org/bugzilla/show_bug.cgi?id=57775
Related: https://issues.apache.org/jira/browse/TIKA-2479
Comment 1 Dominik Stadler 2018-01-01 14:55:24 UTC
Updated javadoc via r1819774.
Comment 2 Geoff Baskwill 2018-01-01 15:45:36 UTC
Thank you!