Bug 62004 - get math formula using CTDrawing.getOneCellAnchorArray().xmlText() messy code
Summary: get math formula using CTDrawing.getOneCellAnchorArray().xmlText() messy code
Status: RESOLVED DUPLICATE of bug 59268
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.17-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 59022
Blocks:
  Show dependency tree
 
Reported: 2018-01-16 08:22 UTC by 578372374
Modified: 2018-01-17 02:30 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 578372374 2018-01-16 08:22:51 UTC
I insert a math formula with office excel 2016,then i use org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTDrawing.getOneCellAnchorArray(i).xmlText() to get it,then i got messy code.
My formula is 𝐴=𝜋𝑟^2,and what the xml i got is:??=????^2.
My jar: poi 3.17  xmlbeans 2.6.0
Besides that ,if i just open the xlsx file with poi ,then just save it without any operation,it causes the math formula messy code too.
Comment 1 PJ Fanning 2018-01-16 10:19:27 UTC
Could you try https://github.com/pjfanning/xmlbeans instead of apache xmlbeans?

*** This bug has been marked as a duplicate of bug 59268 ***
Comment 2 578372374 2018-01-17 02:30:49 UTC
Thanks for your reply,after using xbean.jar i solve the problem,Thanks again.By the way,could you please replace xmlbeans-2.6.0.jar with xbean.jar in poi 3.17
so that others will not meet this bug.