Bug 62016 - failing to create davlockdb
Summary: failing to create davlockdb
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_dav_fs (show other bugs)
Version: 2.4-HEAD
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-18 14:54 UTC by boec0025
Modified: 2018-02-02 12:25 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boec0025 2018-01-18 14:54:20 UTC
i am running fc 27.  i just upgraded from fc 24.  everything worked perfect in 24 but after upgrading to 27, i cannot write to my dav site.  i used the same config file and it didnt work so i went through and updated my config file and it wouldnt work...i keep getting the error...

[Wed Jan 17 04:39:28.449595 2018] [dav:error] [pid 6908:tid 140437503338240] [client XXX.XXX.XXX.XXX:56270] The locks could not be queried for verification against a possible "If:" header.  [500, #0]
[Wed Jan 17 04:39:28.449606 2018] [dav:error] [pid 6908:tid 140437503338240] [client XXX.XXX.XXX.XXX:56270] Could not open the lock database.  [500, #400]
[Wed Jan 17 04:39:28.449610 2018] [dav:error] [pid 6908:tid 140437503338240] (20019)DSO load failed: [client XXX.XXX.XXX.XXX:56270] Could not open property database.  [500, #1] 

i have tried every variant of creating this including setting the lock db directory to 777 and cannot get it to work.  i have taken down selinux and still not luck.  after spending hours and hours trying everything to isolate it, i can only think it must just be dav fs failing to create the lock db only.  

i can find no other way to troubleshoot this further.  if there is a way please let me know...
Comment 1 boec0025 2018-02-02 12:25:00 UTC
after searching for what seemed like years and years and years and years i finally fingered it out. APPARENTLY, apache uses apr-util to build a berkeley db for the dav lock db...of course, right?! well, the issue with that is httpd does NOT have a dependency of apr-util-bdb. why is that important, well those are the drivers for the apr-util. without those apr-util was not working right and not building the davlockdb. once i installed those and restarted the pc, dav once again works. HOORAY FOR ME!

it is related to...

https://bugzilla.redhat.com/show_bug.cgi?id=1491151