Bug 62029 - getting error "DataEncoding: null" in server response
Summary: getting error "DataEncoding: null" in server response
Status: RESOLVED INVALID
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.3
Hardware: PC All
: P1 blocker (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2018-01-22 13:38 UTC by Ajay Sanodaria
Modified: 2018-01-28 13:24 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ajay Sanodaria 2018-01-22 13:38:54 UTC
Hi,

Steps taken:
I have recorded a script through BlazeMeter and exported it into .jmx format.
I am getting error code Response code: 400
Response message: BAD REQUEST while runngig a script. 
HTTPSampleResult fields:
ContentType: application/json
DataEncoding: null

It's throwing this error when pop up wizard is come in picture.

-------------
Request:
-------------
POST data:
---2XjOrgvPmAhzM8OuXmi0HM39s7GZ0
Content-Disposition: form-data; name="cmd"
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 8bit

Cookie Data:
user_id=; system_user=; full_name=; sid=7c4ef699eea3edfd8b624e1825d8b0d12dc2c07738d56200c74f0c55; io=u6PHhNN_ZQYYSqinAAIx

Request Headers:
Connection: keep-alive
Accept: application/json, text/javascript, */*; q=0.01
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Accept-Language: en-US,en;q=0.9,gu;q=0.8
Accept-Encoding: gzip, deflate
Content-Length: 245
Content-Type: multipart/form-data; boundary=-2XjOrgvPmAhzM8OuXmi0HM39s7GZ0
Host:

-----------------
Sampler Result:
-----------------

Thread Name: Thread Group 1-1
Sample Start: 2018-01-22 18:46:30 IST
Load time: 529
Connect Time: 2
Latency: 529
Size in bytes: 555
Sent bytes:834
Headers size in bytes: 452
Body size in bytes: 103
Sample Count: 1
Error Count: 1
Data type ("text"|"bin"|""): text
Response code: 400
Response message: BAD REQUEST

Response headers:
HTTP/1.1 400 BAD REQUEST
Server: nginx/1.10.3 (Ubuntu)
Date: Mon, 22 Jan 2018 13:18:04 GMT
Content-Type: application/json
Content-Length: 103
Connection: keep-alive
Set-Cookie: user_image=; Path=/
Set-Cookie: user_id=; Path=/
Set-Cookie: system_user=yes; Path=/
Set-Cookie: full_name=; Path=/
Set-Cookie: sid=7c4ef699eea3edfd8b624e1825d8b0d12dc2c07738d56200c74f0c55; Expires=Thu, 25-Jan-2018 13:18:04 GMT; Path=/


HTTPSampleResult fields:
ContentType: application/json
DataEncoding: null
Comment 1 Philippe Mouawad 2018-01-28 13:24:09 UTC
Hello,
From your report:
1/ I don't understand what error you get in "popup wizard" ?
2/ DataEncoding null is not an error
3/ Can you explain the full process you do ?
4/ Blazemeter recorder is a 3rd party tool , the issue might be there. Try using core JMeter recorder

Bugzilla is not a support forum, please user mailing list.