Bug 62050 - Java throws me the WARNING
Summary: Java throws me the WARNING
Status: RESOLVED DUPLICATE of bug 61572
Alias: None
Product: POI
Classification: Unclassified
Component: XWPF (show other bugs)
Version: 4.0.x-dev
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-26 18:15 UTC by Sergei
Modified: 2018-01-30 13:39 UTC (History)
0 users



Attachments
WARNING (48.05 KB, image/png)
2018-01-26 18:15 UTC, Sergei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei 2018-01-26 18:15:18 UTC
Created attachment 35699 [details]
WARNING

Hello,

I was trying to export data from .xlsx document to the console in Intellij IDEA IDE, but Java throws me this warning: 
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.poi.openxml4j.util.ZipSecureFile$1 (file:/D:/Users/Sergei/Documents/JavaProjects/171rdb043/src/poi-3.17/poi-ooxml-3.17.jar) to field java.io.FilterInputStream.in
WARNING: Please consider reporting this to the maintainers of org.apache.poi.openxml4j.util.ZipSecureFile$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

I'm using JDK 9 and JRE 9.
There is no problem in Intellij IDEA.
Could you explain me what may cause this problem?
I found that it might be probably bug in your API.
Screenshot in attachment.

Thanks,
Sergei
Comment 1 PJ Fanning 2018-01-30 13:39:38 UTC

*** This bug has been marked as a duplicate of bug 61572 ***