Bug 62062 - ThroughputController: StackOverFlowError triggered when throughput=0 (Total Executions or Percentage Executions)
Summary: ThroughputController: StackOverFlowError triggered when throughput=0 (Total E...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-30 12:45 UTC by Artem Fedorov
Modified: 2018-01-31 08:10 UTC (History)
1 user (show)



Attachments
Test plan that reproduces this bug (4.32 KB, application/xml)
2018-01-30 12:45 UTC, Artem Fedorov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Fedorov 2018-01-30 12:45:46 UTC
Created attachment 35708 [details]
Test plan that reproduces this bug

When I ran the following Test Plan I got the java.lang.StackOverflowError

   - innerLoop
     - ThroughputController (sut)
        - sampler one
        - sampler two




...
at org.apache.jmeter.control.GenericController.nextIsAController(GenericController.java:222)
at org.apache.jmeter.control.GenericController.next(GenericController.java:173)
at org.apache.jmeter.control.LoopController.next(LoopController.java:128)
at org.apache.jmeter.control.LoopController.nextIsNull(LoopController.java:163)
at org.apache.jmeter.control.GenericController.next(GenericController.java:168)
at org.apache.jmeter.control.LoopController.next(LoopController.java:128)
at org.apache.jmeter.control.GenericController.nextIsAController(GenericController.java:222)
at org.apache.jmeter.control.GenericController.next(GenericController.java:173)
at org.apache.jmeter.control.LoopController.next(LoopController.java:128)
at org.apache.jmeter.control.LoopController.nextIsNull(LoopController.java:163)
at org.apache.jmeter.control.GenericController.next(GenericController.java:168)
at org.apache.jmeter.control.LoopController.next(LoopController.java:128)
at org.apache.jmeter.control.GenericController.nextIsAController(GenericController.java:222)
at org.apache.jmeter.control.GenericController.next(GenericController.java:173)
...
Comment 1 Philippe Mouawad 2018-01-30 21:38:20 UTC
https://github.com/apache/jmeter/pull/373
Comment 2 Philippe Mouawad 2018-01-30 21:38:35 UTC
Author: pmouawad
Date: Tue Jan 30 21:38:15 2018
New Revision: 1822704

URL: http://svn.apache.org/viewvc?rev=1822704&view=rev
Log:
Bug 62062 - ThroughputController: StackOverFlowError triggered when throughput=0 (Total Executions or Percentage Executions)
This closes #373
Partly contributed by Artem Fedorov
Bugzilla Id: 62062

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ThroughputController.java
    jmeter/trunk/test/src/org/apache/jmeter/control/ThroughputControllerSpec.groovy
    jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2018-01-30 21:39:14 UTC
Thanks for report and PR.
I amended the fix to also handle SO if Percentage=0

Please test and confirm fix is ok for you.
Regards
Comment 4 Artem Fedorov 2018-01-31 08:10:55 UTC
This fix works for me

Thanks