Bug 62065 - Use Maven artifact for JAF Module instead of embedded module
Summary: Use Maven artifact for JAF Module instead of embedded module
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk, JDK9
: 62835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-30 22:21 UTC by Philippe Mouawad
Modified: 2018-10-19 20:06 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2018-01-30 22:21:38 UTC
Related to Bug 61529.

------------------------------------------------------------
Alan Bateman wrote:
`--add-modules java.activation` will cease to work once the java.activation module has been dropped from Java SE and the JDK (details in JEP 320 [1]). The JavaBeans Activation Framework is published to Maven Central so no need to depend on the version included in the JDK.

[1] http://openjdk.java.net/jeps/320

[reply] [−] Comment 17 Philippe Mouawad 2018-01-29 13:13:13 UTC

(In reply to Alan Bateman from comment #16)
> `--add-modules java.activation` will cease to work once the java.activation
> module has been dropped from Java SE and the JDK (details in JEP 320 [1]).
> The JavaBeans Activation Framework is published to Maven Central so no need
> to depend on the version included in the JDK.
> 
> [1] http://openjdk.java.net/jeps/320

Hello Alan,
Thanks for your note.
In which version of Java SE/JDK will you be dropping it ?

Thank you

[reply] [−] Comment 18 Alan Bateman 2018-01-30 11:10:36 UTC

The JEP is currently targeted to JDK 11 (look for the release field near the top). The JEP also has the Maven coordinates for the standalone version of JAF.
Comment 1 Philippe Mouawad 2018-03-08 22:12:28 UTC
Author: pmouawad
Date: Thu Mar  8 22:02:43 2018
New Revision: 1826280

URL: http://svn.apache.org/viewvc?rev=1826280&view=rev
Log:
Bug 62065 - Use Maven artifact for JAF Module instead of embedded module
Bugzilla Id: 62065

Added:
    jmeter/trunk/licenses/bin/javax.activation-api-1.2.0.txt   (with props)
Modified:
    jmeter/trunk/LICENSE
    jmeter/trunk/build.properties
    jmeter/trunk/build.xml
    jmeter/trunk/eclipse.classpath
    jmeter/trunk/lib/   (props changed)
    jmeter/trunk/lib/aareadme.txt
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2018-03-08 23:00:47 UTC
Author: pmouawad
Date: Thu Mar  8 22:59:58 2018
New Revision: 1826285

URL: http://svn.apache.org/viewvc?rev=1826285&view=rev
Log:
Bug 62065 - Use Maven artifact for JAF Module instead of embedded module
Add  "com.sun.activation" / javax.activation
Bugzilla Id: 62065

Added:
    jmeter/trunk/licenses/bin/javax.activation-1.2.1.txt   (with props)
Modified:
    jmeter/trunk/LICENSE
    jmeter/trunk/build.properties
    jmeter/trunk/build.xml
    jmeter/trunk/eclipse.classpath
    jmeter/trunk/lib/   (props changed)
    jmeter/trunk/lib/aareadme.txt
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
Comment 3 Philippe Mouawad 2018-09-09 20:34:01 UTC
Author: pmouawad
Date: Sun Sep  9 20:31:18 2018
New Revision: 1840433

URL: http://svn.apache.org/viewvc?rev=1840433&view=rev
Log:
Bug 62065 - Use Maven artifact for JAF Module instead of embedded module

Bugzilla Id: 62065

Modified:
    jmeter/trunk/bin/jmeter
    jmeter/trunk/bin/jmeter.bat
    jmeter/trunk/bin/jmeter.sh
Comment 4 Philippe Mouawad 2018-10-19 20:06:36 UTC
*** Bug 62835 has been marked as a duplicate of this bug. ***