Bug 62097 - Cannot copy Aggregate Report
Summary: Cannot copy Aggregate Report
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 62474 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-12 14:36 UTC by Steve
Modified: 2018-06-20 10:23 UTC (History)
2 users (show)



Attachments
Change model only when new data has arrived (1.07 KB, patch)
2018-02-12 15:26 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2018-02-12 14:36:49 UTC
Steps to reproduce:

Add 'Aggregate Report' listener to Test Plan
Browse to load a .jtl file
Click on the Aggregate Report results window
Select ALL (windows CTRL+A)
Copy (CTRL+C)

When I try the above actions (which have worked in previous jmeter versions)
After 'Selecting All' (CTRL+A) the selection is selected for a brief moment then automatically deselected, as such I cannot copy the Aggregate Report into Excel
Comment 1 Felix Schumacher 2018-02-12 15:26:13 UTC
Created attachment 35727 [details]
Change model only when new data has arrived

Add same check as in SummaryReport.
Comment 2 Felix Schumacher 2018-02-12 15:30:52 UTC
The attached will only reset the selection when new data has arrived (and the GUI gets refreshed).

You can get more time to select in the current version by specifying a higher value for the property jmeter.gui.refresh_period (the default is 500 ms).

Can you check, whether the current behaviour of Summary Report would be enough for your use case?
Comment 3 Felix Schumacher 2018-02-12 18:58:50 UTC
Date: Mon Feb 12 18:58:24 2018
New Revision: 1824054

URL: http://svn.apache.org/viewvc?rev=1824054&view=rev
Log:
Update JTable in Aggregate Report only when new data has arrived.

That way selections of rows will be kept longer around.

Bugzilla Id: 62097

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/StatVisualizer.java
    jmeter/trunk/xdocs/changes.xml
Comment 4 Steve 2018-02-14 16:05:26 UTC
Hi,
I just tested the nightly build:
apache-jmeter-r1824054

it seems to work perfectly now for the aggregate report
it updates correctly when a test is running
It allows me to 'select all' when the test has stopped or I manually load a .jtl file

thank you Felix


Steve
Comment 5 Felix Schumacher 2018-06-19 17:33:17 UTC
*** Bug 62474 has been marked as a duplicate of this bug. ***
Comment 6 Stephen 2018-06-20 10:23:46 UTC
Confirmed working for me on apache-jmeter-r1833661