Bug 62122 - undefined symbol: SSL_COMP_free_compression_methods
Summary: undefined symbol: SSL_COMP_free_compression_methods
Status: RESOLVED FIXED
Alias: None
Product: Tomcat Native
Classification: Unclassified
Component: Library (show other bugs)
Version: 1.2.14
Hardware: PC Linux
: P2 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
: 62428 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-21 17:12 UTC by jballon
Modified: 2018-06-06 11:52 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jballon 2018-02-21 17:12:17 UTC
OpenSSL 1.1.0 removed this function, https://www.openssl.org/docs/man1.1.0/ssl/SSL_COMP_free_compression_methods.html 

native/src/ssl.c

366 #if OPENSSL_VERSION_NUMBER >= 0x1000200fL
367     SSL_COMP_free_compression_methods();
368 #endif

this will need to be patched, suggestion below this is untested:

366 #if OPENSSL_VERSION_NUMBER >= 0x1000200fL && OPENSSL_VERSION_NUMBER < 0x10100000L 
367     SSL_COMP_free_compression_methods();
368 #endif
Comment 1 jfclere 2018-06-04 16:18:40 UTC
per openssl doc it says it is deprecated and do nothing, so I close the bug.
Comment 2 Christopher Schultz 2018-06-04 18:23:27 UTC
*** Bug 62428 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Schultz 2018-06-04 18:24:41 UTC
Re-opening original BZ issue.

Seems like this needs to be fixed by capping the OpenSSL version number used in the #ifdef.

jballon, would you mind actually testing your proposed solution?
Comment 4 jfclere 2018-06-05 06:06:44 UTC
I think the problen is fixed by r1832911.
Could you please retest?
Comment 5 jballon 2018-06-05 21:33:26 UTC
I successfully rested with this fix. I verified that I no longer received the error message.