Bug 62219 - Exception when scroll mouse on component sub menu
Summary: Exception when scroll mouse on component sub menu
Status: RESOLVED DUPLICATE of bug 56150
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-26 12:14 UTC by orimarko
Modified: 2018-03-26 12:53 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description orimarko 2018-03-26 12:14:13 UTC
I click on Add -> any option as Config Elements and then when mouse is on sub menu as "CSV Data Set Config" scroll mouse up/down

Exception in log 

2018-03-26 14:46:22,799 DEBUG o.a.j.g.GuiPackage: Updating gui to new node
2018-03-26 14:46:22,800 DEBUG o.a.j.g.GuiPackage: Showing pop up for org.apache.jmeter.gui.MainFrame$1[,0,0,374x759,invalid,alignmentX=0.0,alignmentY=0.0,border=javax.swing.plaf.synth.SynthBorder@29c29532,flags=16777704,maximumSize=,minimumSize=,preferredSize=,editable=false,invokesStopCellEditing=false,largeModel=false,rootVisible=false,rowHeight=0,scrollsOnExpand=true,showsRootHandles=true,toggleClickCount=2,visibleRowCount=20] at x,y = 77,15
2018-03-26 14:46:24,618 ERROR o.a.j.JMeter: Uncaught exception: 
java.lang.ArrayIndexOutOfBoundsException: -38
    at org.apache.jorphan.gui.MenuScroller.refreshMenu(MenuScroller.java:550) ~[jorphan.jar:4.0 r1823414]
    at org.apache.jorphan.gui.MenuScroller.access$300(MenuScroller.java:55) ~[jorphan.jar:4.0 r1823414]
    at org.apache.jorphan.gui.MenuScroller$MouseScrollListener.mouseWheelMoved(MenuScroller.java:576) ~[jorphan.jar:4.0 r1823414]
    at java.awt.Component.processMouseWheelEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.processEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Container.processEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Container.dispatchEventToSelf(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.dispatchMouseWheelToAncestor(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Container.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.dispatchEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Container.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Window.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.Component.dispatchEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue.access$400(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue$3.run(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue$3.run(Unknown Source) ~[?:1.8.0_25]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_25]
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source) ~[?:1.8.0_25]
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue$4.run(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue$4.run(Unknown Source) ~[?:1.8.0_25]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_25]
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventQueue.dispatchEvent(Unknown Source) ~[?:1.8.0_25]
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [?:1.8.0_25]
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [?:1.8.0_25]
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) [?:1.8.0_25]
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:1.8.0_25]
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:1.8.0_25]
    at java.awt.EventDispatchThread.run(Unknown Source) [?:1.8.0_25]

Happens also in previous version 3.3
Comment 1 Philippe Mouawad 2018-03-26 12:53:09 UTC

*** This bug has been marked as a duplicate of bug 56150 ***