Bug 62230 - Formula evaluation fails when using matrix multiplication within SUM function call with #VALUE!
Summary: Formula evaluation fails when using matrix multiplication within SUM function...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.16-FINAL
Hardware: PC Linux
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-29 11:35 UTC by azad
Modified: 2019-02-12 16:00 UTC (History)
0 users



Attachments
test cases with screen shots (35.01 KB, application/pdf)
2018-03-29 11:35 UTC, azad
Details
source and input files (40.31 KB, application/zip)
2018-04-03 14:52 UTC, azad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description azad 2018-03-29 11:35:47 UTC
Created attachment 35823 [details]
test cases with screen shots

Similar to bug https://bz.apache.org/bugzilla/show_bug.cgi?id=61116 .

Please check the attached pdf for visual detail.

How could I download the intermediate build to test, I could only test with 3.17-Final where this bug still remains.
Comment 1 Javen O'Neal 2018-03-31 10:09:06 UTC
POI array formula support definitely needs some love.

Would you be willing to write a unit test demonstrating the problem? With that, we'd be halfway to a solution.

This might be a good place to write it:
https://svn.apache.org/viewvc/poi/trunk/src/testcases/org/apache/poi/ss/formula/eval/TestFormulaBugs.java?view=log
Comment 2 azad 2018-04-03 14:52:28 UTC
Created attachment 35835 [details]
source and input files
Comment 3 azad 2018-04-04 11:16:12 UTC
(In reply to Javen O'Neal from comment #1)
> POI array formula support definitely needs some love.
> 
> Would you be willing to write a unit test demonstrating the problem? With
> that, we'd be halfway to a solution.
> 
> This might be a good place to write it:
> https://svn.apache.org/viewvc/poi/trunk/src/testcases/org/apache/poi/ss/
> formula/eval/TestFormulaBugs.java?view=log

Hi,
I have added my own test source and input files.


I hope you find it easy to reproduce the situation.
Comment 4 Yegor Kozlov 2019-02-12 16:00:49 UTC
The problem is no longer reproducible with the latest build from trunk. There have been improvements in evaluation of array formulas which seem to have fixed this.

Yegor