Bug 62238 - Add ability to Switch to next iteration of Current Loop
Summary: Add ability to Switch to next iteration of Current Loop
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2018-03-31 10:28 UTC by Philippe Mouawad
Modified: 2018-09-05 14:25 UTC (History)
1 user (show)



Attachments
Test Action screenshot (80.89 KB, image/png)
2018-03-31 12:41 UTC, Philippe Mouawad
Details
Result Status Action Handler Screenshot (69.22 KB, image/png)
2018-03-31 12:42 UTC, Philippe Mouawad
Details
Test Plan showing current bug in nightly (7.25 KB, application/xml)
2018-06-16 12:16 UTC, Philippe Mouawad
Details
Test plan to test Result Status Action Handler (23.11 KB, application/xml)
2018-07-03 20:36 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2018-03-31 10:28:02 UTC
It is very frequent in scripting that in case of error or under certain conditions that we want to do the equivalent of "continue" in current loop, meaning switch to next iteration of current Loop.

Currently JMeter allows only restarting the main thread loop which is too much for example in the case of a scenario like this:

- 1 Login
- X Executions of some treatment in a loop.

In case of error or under certain conditions we just want to go to next iteration , the workaround today is to nest IfController.


This enhancement will introduce the feature and make it available in :
- Test Action
- Result Status Handler
Comment 1 Philippe Mouawad 2018-03-31 10:33:52 UTC
Author: pmouawad
Date: Sat Mar 31 10:32:33 2018
New Revision: 1828095

URL: http://svn.apache.org/viewvc?rev=1828095&view=rev
Log:
Bug 62238 - Add ability to Switch to next iteration of Current Loop
Contributed by Ubik Load Pack
Bugzilla Id: 62238

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/sampler/TestAction.java
    jmeter/trunk/src/components/org/apache/jmeter/sampler/gui/TestActionGui.java
    jmeter/trunk/src/core/org/apache/jmeter/gui/OnErrorPanel.java
    jmeter/trunk/src/core/org/apache/jmeter/reporters/ResultAction.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/src/core/org/apache/jmeter/samplers/SampleResult.java
    jmeter/trunk/src/core/org/apache/jmeter/testelement/OnErrorTestElement.java
    jmeter/trunk/src/core/org/apache/jmeter/threads/AbstractThreadGroup.java
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterContext.java
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2018-03-31 12:31:53 UTC
Author: pmouawad
Date: Sat Mar 31 12:27:47 2018
New Revision: 1828103

URL: http://svn.apache.org/viewvc?rev=1828103&view=rev
Log:
Bug 62238 - Add ability to Switch to next iteration of Current Loop
Fix regression
Bugzilla Id: 62238

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
Comment 3 Philippe Mouawad 2018-03-31 12:41:46 UTC
Created attachment 35831 [details]
Test Action screenshot

As part of this bug, Test Action UI has been reworked.
Comment 4 Philippe Mouawad 2018-03-31 12:42:19 UTC
Created attachment 35832 [details]
Result Status Action Handler Screenshot

As part of this bug, Result Status Action Handler UI has been reworked.
Comment 5 Philippe Mouawad 2018-03-31 12:43:16 UTC
As part of this commit but related to Bug 62239, code for breaking loop is in WORK IN PROGRESS.
Comment 6 UbikLoadPack support 2018-05-18 16:07:05 UTC
Hello,
We detected an issue when option is enabled.
Reopening for now, will provide more details later.

Thanks
Comment 7 Philippe Mouawad 2018-06-16 12:16:17 UTC
Created attachment 35968 [details]
Test Plan showing current bug in nightly

On second iteration of Thread Group, the loop is not entered anymore.
Comment 8 Philippe Mouawad 2018-06-17 09:00:46 UTC
(In reply to Philippe Mouawad from comment #7)
> Created attachment 35968 [details]
> Test Plan showing current bug in nightly
> 
> On second iteration of Thread Group, the loop is not entered anymore.

because the LC iteration has not been reset
Comment 9 Philippe Mouawad 2018-07-03 20:36:39 UTC
Created attachment 36005 [details]
Test plan to test Result Status Action Handler
Comment 10 Philippe Mouawad 2018-07-05 20:38:58 UTC
Author: pmouawad
Date: Wed Jul  4 12:04:56 2018
New Revision: 1835050

URL: http://svn.apache.org/viewvc?rev=1835050&view=rev
Log:
Bug 62238 - Add ability to Switch to next iteration of Current Loop

Fix failure of test Bug 62239, add tests for 62238
Bugzilla Id: 62238

Added:
    jmeter/trunk/bin/testfiles/TestResultStatusAction.csv
    jmeter/trunk/bin/testfiles/TestResultStatusAction.jmx   (with props)
    jmeter/trunk/bin/testfiles/TestResultStatusAction.xml   (with props)
Modified:
    jmeter/trunk/build.xml
    jmeter/trunk/src/core/org/apache/jmeter/control/WhileController.java

Author: fschumacher
Date: Wed Jul  4 18:46:28 2018
New Revision: 1835078

URL: http://svn.apache.org/viewvc?rev=1835078&view=rev
Log:
Don't store the size of the responses for the samplers in this test.

It is fragile and breaks the integration tests.
Bugzilla Id: 62238

Modified:
    jmeter/trunk/bin/testfiles/TestResultStatusAction.jmx
    jmeter/trunk/bin/testfiles/TestResultStatusAction.xml


Author: pmouawad
Date: Wed Jul  4 12:20:54 2018
New Revision: 1835052

URL: http://svn.apache.org/viewvc?rev=1835052&view=rev
Log:
Bug 62238 - Add ability to Switch to next iteration of Current Loop

Enable disabled thread groups
Bugzilla Id: 62238

Modified:
    jmeter/trunk/bin/testfiles/TestResultStatusAction.jmx


Author: pmouawad
Date: Tue Jul  3 20:16:38 2018
New Revision: 1835022

URL: http://svn.apache.org/viewvc?rev=1835022&view=rev
Log:
Bug 62238 - Add ability to Switch to next iteration of Current Loop

Fix issue in nightly
Bugzilla Id: 62238

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ForeachController.java
    jmeter/trunk/src/core/org/apache/jmeter/control/IteratingController.java
    jmeter/trunk/src/core/org/apache/jmeter/control/LoopController.java
    jmeter/trunk/src/core/org/apache/jmeter/control/WhileController.java