Bug 62243 - Dashboard : make option "--forceDeleteResultFile"/"-f" option delete folder referenced by "-o" option
Summary: Dashboard : make option "--forceDeleteResultFile"/"-f" option delete folder r...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 62661 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-01 05:57 UTC by orimarko
Modified: 2018-09-01 13:45 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description orimarko 2018-04-01 05:57:45 UTC
Need to add option to override dashboard results in order to re-execute same command.

Based on https://stackoverflow.com/questions/49574753/jmeter-command-line-cannot-write-folder-is-not-empty

There's expectation to be able to override dashboard result when executing a non GUI request, currently -f override only jtl file
Comment 1 Philippe Mouawad 2018-04-02 13:38:36 UTC
Author: pmouawad
Date: Mon Apr  2 13:38:08 2018
New Revision: 1828168

URL: http://svn.apache.org/viewvc?rev=1828168&view=rev
Log:
Bug 62243 - Dashboard : make option "--forceDeleteResultFile"/"-f" option delete folder referenced by "-o" option
Bugzilla Id: 62243

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/src/jorphan/org/apache/jorphan/util/JOrphanUtils.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/get-started.xml
Comment 2 Philippe Mouawad 2018-04-02 13:39:30 UTC
Thanks for report.
If you can test next nightly build and report any issue.

Thanks
Comment 3 orimarko 2018-04-02 14:40:02 UTC
It worked in nightly on Windows 7

Thanks
Comment 4 Philippe Mouawad 2018-09-01 13:45:57 UTC
*** Bug 62661 has been marked as a duplicate of this bug. ***