Bug 62260 - Improve Rest support
Summary: Improve Rest support
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks: 60015 60190
  Show dependency tree
 
Reported: 2018-04-05 11:28 UTC by UbikLoadPack support
Modified: 2018-04-05 19:42 UTC (History)
2 users (show)



Attachments
Sampler Parameters Tab screenshot (155.63 KB, image/png)
2018-04-05 11:28 UTC, UbikLoadPack support
Details
Sampler File Upload Tab screenshot (136.37 KB, image/png)
2018-04-05 11:29 UTC, UbikLoadPack support
Details
Request sent (305.15 KB, image/png)
2018-04-05 11:29 UTC, UbikLoadPack support
Details

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2018-04-05 11:28:42 UTC
Created attachment 35841 [details]
Sampler Parameters Tab screenshot

Hello,

In order to test RESTFUL applications JMeter has currently some limits:

- As per Bug 60015, multipart/form-data only works for POST, it should work for other methods
- As per discussion on dev mailing list (MultiPart/form-data : Supporting JSON body + file upload : http://mail-archives.apache.org/mod_mbox/jmeter-dev/201703.mbox/%3CCAH9fUpb9pAJYUchwUbvtA5VC_Cr5B4pSaR62pXYg9sF2Z1-kMg%40mail.gmail.com%3E), one cannot specify some content-type on parts of a multipart. Providing this would make JMeter even more powerful than Postman on this level


As a minor side effect, it will drop the feature related to Bug 60092 (maybe it can be added later)
Comment 1 UbikLoadPack support 2018-04-05 11:29:03 UTC
Created attachment 35842 [details]
Sampler File Upload Tab screenshot
Comment 2 UbikLoadPack support 2018-04-05 11:29:24 UTC
Created attachment 35843 [details]
Request sent
Comment 3 Philippe Mouawad 2018-04-05 19:11:19 UTC
Author: pmouawad
Date: Thu Apr  5 19:10:44 2018
New Revision: 1828467

URL: http://svn.apache.org/viewvc?rev=1828467&view=rev
Log:
Bug 62260 - Improve Rest support
This also fixes:
- Bug 60190 - Content-Type is added for POST unconditionally
Bug 60015 - Multipart/form-data works only for POST using HTTPClient4 while it should for PUT, DELETE...

Contributed  by UbikLoadPack
Bugzilla Id: 62260

Modified:
    jmeter/trunk/bin/jmeter.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/config/MultipartUrlConfig.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/config/gui/UrlConfigGui.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/HTTPArgumentsPanel.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/proxy/DefaultSamplerCreator.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPAbstractImpl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPJavaImpl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/PostWriter.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/HTTPArgument.java
    jmeter/trunk/test/src/org/apache/jmeter/protocol/http/sampler/PostWriterTest.java
    jmeter/trunk/test/src/org/apache/jmeter/protocol/http/sampler/TestHTTPSamplersAgainstHttpMirrorServer.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/properties_reference.xml
Comment 4 Philippe Mouawad 2018-04-05 19:11:46 UTC
*** Bug 60015 has been marked as a duplicate of this bug. ***
Comment 5 Philippe Mouawad 2018-04-05 19:42:15 UTC
Author: pmouawad
Date: Thu Apr  5 19:41:52 2018
New Revision: 1828470

URL: http://svn.apache.org/viewvc?rev=1828470&view=rev
Log:
Bug 62260
Revert changes unrelated to issue + issue in java.
Add test case for No KeepAlive to ensure Connection: close is present
Bugzilla Id: 62260

Modified:
    jmeter/trunk/bin/testfiles/TestKeepAlive.csv
    jmeter/trunk/bin/testfiles/TestKeepAlive.jmx
    jmeter/trunk/bin/testfiles/TestKeepAlive.xml
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPJavaImpl.java