Bug 62267 - Create a SLA Assertion or Listener that makes JMeter fail based on test statistics
Summary: Create a SLA Assertion or Listener that makes JMeter fail based on test stati...
Status: RESOLVED DUPLICATE of bug 64457
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-06 13:49 UTC by UbikLoadPack support
Modified: 2020-05-20 12:04 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2018-04-06 13:49:21 UTC
Such element could take into account:

- Response time percentile during a period of time
- Error rate increase for a duration 
- Error rate max limit


a) It would be used to emit a log :
- Test Failed / Test Successful
b) It would be present in HTML report
c) It would influence JMeter exit code which would be helpful in CI tools


Such request is very frequently seen in Stackoverflow questions.
Comment 1 Philippe Mouawad 2020-05-20 12:04:28 UTC

*** This bug has been marked as a duplicate of bug 64457 ***