Bug 62381 - Fix rendering of AutoShapes
Summary: Fix rendering of AutoShapes
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: SL Common (show other bugs)
Version: 4.0-dev
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 59004 53176
Blocks:
  Show dependency tree
 
Reported: 2018-05-16 20:16 UTC by Andreas Beeker
Modified: 2018-05-16 20:33 UTC (History)
0 users



Attachments
Arrows test (855.69 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-05-16 20:16 UTC, Andreas Beeker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Beeker 2018-05-16 20:16:21 UTC
Created attachment 35938 [details]
Arrows test

I recently received a test file, which shows some rendering errors.

The problem is/was that the patch for #53176 was not applied to the computed outlines. By moving the code to getAnchor() also the outlines receive that normalized anchor.

Furthermore I've disabled the evaluation of adjust values for HSLF, because the auto shapes look usually more distorted when the adjust values (instead of the defaults) are used.

And last but not least, there the parent relation/shape wasn't initialized in XSLF.
Comment 1 Andreas Beeker 2018-05-16 20:32:35 UTC
Applied via r1831743

Btw. Libre Office currenly also distorts the arrows