Bug 62406 - Illegal reflective access
Summary: Illegal reflective access
Status: RESOLVED DUPLICATE of bug 62151
Alias: None
Product: POI
Classification: Unclassified
Component: POIFS (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-24 06:51 UTC by Kalakrishnan
Modified: 2019-03-01 09:32 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kalakrishnan 2018-05-24 06:51:54 UTC
Warning message when running under Java versions 9 / 10

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.poi.poifs.nio.FileBackedDataSource$1 (file:/name_of_Jar_file) to method java.nio.DirectByteBuffer.cleaner()
WARNING: Please consider reporting this to the maintainers of org.apache.poi.poifs.nio.FileBackedDataSource$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Comment 1 Dominik Stadler 2018-05-24 08:04:20 UTC

*** This bug has been marked as a duplicate of bug 62151 ***
Comment 2 Markus Kilås 2019-02-28 10:03:23 UTC
We are seeing this as well on Java 11. Additionally on Windows this also seems to mean that the file is not getting properly closed.

An exception is being catched in FileBackedDataSource.unmap():

class org.apache.poi.poifs.nio.FileBackedDataSource$1 cannot access class jdk.internal.ref.Cleaner (in module java.base) because module java.base does not export jdk.internal.ref to unnamed module
Comment 3 PJ Fanning 2019-03-01 09:32:14 UTC
Markus - this issue is closed as a duplicate - could you comment on https://bz.apache.org/bugzilla/show_bug.cgi?id=62151 ?