Bug 62417 - configure: error: cannot run /usr/local/bin/bash build/config.sub similar to 21377
Summary: configure: error: cannot run /usr/local/bin/bash build/config.sub similar to ...
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.5-HEAD
Hardware: Sun Solaris
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 00:45 UTC by Dennis Clarke
Modified: 2018-06-19 19:11 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Clarke 2018-05-30 00:45:02 UTC
a configure script is easily made : 

beta $ autoconf --force --include=/usr/local/include --warnings=all

however configure fails with : 

.
.
.
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking for grep that handles long lines and -e... /usr/local/bin/grep
checking for egrep... /usr/local/bin/grep -E
configure: error: cannot run /usr/local/bin/bash build/config.sub

beta $ 

beta $ find . | grep "config\.sub"
beta $ find . | grep "config\.guess"

Looks like the files are entirely absent. 

As a hack I can take them from httpd-2.4.33 src dir. 
However a bunch of files are absent it seems : 

./build/config.guess: No such file or directory
./build/config.sub: No such file or directory
./build/config_vars.mk: No such file or directory
./build/config_vars.sh: No such file or directory
./build/ltmain.sh: No such file or directory
./build/rules.mk: No such file or directory
Comment 1 Dennis Clarke 2018-05-30 00:55:18 UTC
Actually the three missing files are : 

build/config.guess
build/config.sub
build/ltmain.sh

after ripping them out of the httpd-2.4.33 src tree then configure runs 
reasonably well.
Comment 2 Dennis Clarke 2018-05-30 00:56:00 UTC

sorry .. also missing : 

config.status: error: cannot find input file: `include/ap_config_auto.h.in'
Comment 3 Eric Covener 2018-05-30 01:26:36 UTC
are you missing ./buildconf ?
Comment 4 Dennis Clarke 2018-05-30 15:56:41 UTC
The file buildconf exists just fine :

beta $ ls -lapb
total 4994
drwxr-xr-x  14 dclarke  devl          62 May 30 01:25 ./
drwxrwxrwt   5 root     root          16 May 30 01:25 ../
-rw-r--r--   1 dclarke  devl           0 May 30 00:58 .deps
-rw-r--r--   1 dclarke  devl       13895 May 28 19:44 .gdbinit
drwxr-xr-x   2 dclarke  devl           2 May 30 01:01 .libs/
drwxr-xr-x   4 dclarke  devl           8 May 28 19:44 .svn/
-rw-r--r--   1 dclarke  devl       13496 May 28 19:44 ABOUT_APACHE
-rw-r--r--   1 dclarke  devl       66316 May 28 19:44 Apache-apr2.dsw
-rw-r--r--   1 dclarke  devl       81355 May 28 19:44 Apache.dsw
-rw-r--r--   1 dclarke  devl        2644 May 28 19:44 BuildAll.dsp
-rw-r--r--   1 dclarke  devl        2784 May 28 19:44 BuildBin.dsp
-rw-r--r--   1 dclarke  devl      253032 May 28 19:44 CHANGES
-rw-r--r--   1 dclarke  devl       45172 May 28 19:44 CMakeLists.txt
-rw-r--r--   1 dclarke  devl        3782 May 28 19:44 INSTALL
-rw-r--r--   1 dclarke  devl        2909 May 28 19:44 InstallBin.dsp
-rw-r--r--   1 dclarke  devl        4097 May 28 19:44 LAYOUT
-rw-r--r--   1 dclarke  devl       25478 May 28 19:44 LICENSE
-rw-r--r--   1 dclarke  devl       11245 May 30 00:58 Makefile
-rw-r--r--   1 dclarke  devl       10845 May 28 19:44 Makefile.in
-rw-r--r--   1 dclarke  devl       53539 May 28 19:44 Makefile.win
-rw-r--r--   1 dclarke  devl         720 May 28 19:44 NOTICE
-rw-r--r--   1 dclarke  devl       13884 May 28 19:45 NWGNUmakefile
-rw-r--r--   1 dclarke  devl        4642 May 28 19:44 README
-rw-r--r--   1 dclarke  devl       13317 May 28 19:44 README.cmake
-rw-r--r--   1 dclarke  devl        4418 May 28 19:44 README.platforms
-rw-r--r--   1 dclarke  devl       10184 May 28 19:44 ROADMAP
-rw-r--r--   1 dclarke  devl       32468 May 28 19:44 STATUS
-rw-r--r--   1 dclarke  devl        8183 May 28 19:44 VERSIONING
-rw-r--r--   1 dclarke  devl       24803 May 28 19:44 acinclude.m4
-rw-r--r--   1 dclarke  devl        2512 May 28 19:44 ap.d
-rw-r--r--   1 dclarke  devl        9907 May 28 19:44 apache_probes.d
drwxr-xr-x   2 dclarke  devl           5 May 30 00:21 autom4te.cache/
-rw-r--r--   1 root     root          50 May 30 01:25 bring.log
drwxr-xr-x   6 dclarke  devl          49 May 30 01:23 build/
-rwxr-xr-x   1 dclarke  devl       10679 May 28 19:44 buildconf
-rw-r--r--   1 root     root       13424 May 30 01:23 buildmark.o
-rw-r--r--   1 dclarke  devl       13357 May 28 19:44 config.layout
-rw-r--r--   1 dclarke  devl      159205 May 30 00:58 config.log
-rwxr-xr-x   1 dclarke  devl        1900 May 30 00:57 config.nice
-rwxr-xr-x   1 dclarke  devl       47258 May 30 00:58 config.status
-rwxr-xr-x   1 dclarke  devl     1192476 May 30 00:21 configure
-rw-r--r--   1 dclarke  devl       29527 May 28 19:44 configure.in
drwxr-xr-x  10 dclarke  devl          11 May 28 19:45 docs/
-rw-r--r--   1 dclarke  devl         403 May 28 19:44 emacs-style
-rw-r--r--   1 root     root        3920 May 30 01:25 fidlist.raw
-rwxr-xr-x   1 dclarke  devl     2952208 May 30 01:23 httpd
-rw-r--r--   1 dclarke  devl        2218 May 28 19:45 httpd.dep
-rw-r--r--   1 dclarke  devl        4124 May 28 19:44 httpd.dsp
-rw-r--r--   1 dclarke  devl        8994 May 28 19:45 httpd.mak
drwxr-xr-x   2 dclarke  devl          49 May 30 00:58 include/
-rw-r--r--   1 dclarke  devl       79070 May 28 19:44 libhttpd.dep
-rw-r--r--   1 dclarke  devl       21528 May 28 19:44 libhttpd.dsp
-rw-r--r--   1 dclarke  devl       38913 May 28 19:44 libhttpd.mak
drwxr-xr-x  28 dclarke  devl          34 May 30 00:51 modules/
-rw-r--r--   1 dclarke  devl        1233 May 30 00:58 modules.c
-rw-r--r--   1 dclarke  devl         260 May 30 01:01 modules.lo
-rw-r--r--   1 dclarke  devl       14256 May 30 01:01 modules.o
drwxr-xr-x   7 dclarke  devl          12 May 30 00:51 os/
drwxr-xr-x   4 dclarke  devl         139 May 30 01:22 server/
drwxr-xr-x   2 dclarke  devl           5 May 30 00:51 srclib/
drwxr-xr-x   5 dclarke  devl         117 May 30 01:07 support/
drwxr-xr-x   2 dclarke  devl          17 May 30 00:51 test/

The entire compile goes fine but fairly sure I pulled the wrong branch
from svn repo .. which seems down from my perspective at the moment. 

What I most likely need is : 

$ svn checkout https://209.188.14.144/repos/asf/httpd/httpd/trunk httpd-trunk

Is there some new security in place at apache.org which blocks entire subnets?
I have no access to anything anymore and had to use ssh and remote X-windows
from an office subnet just to see this bug. Everything looks to be down from
my other subnet.  By everything I mean https://svn.apache.org is down, also
this site https://bz.apache.org/ which is not the same as the older bug tracking
site https://issues.apache.org/ which is also ... offline from my perspective.

I think I better look for a bug tracking website or mailist just for the
security or network operations because it is impossible to work on a TLS 1.3
test when the entire apache.org domain is blocked.  Very strange.
Comment 5 Eric Covener 2018-05-30 16:15:08 UTC
(In reply to Dennis Clarke from comment #4)
> The file buildconf exists just fine :

If you're building from trunk you're expected to run ./buildconf before configure
Comment 6 Dennis Clarke 2018-05-30 17:29:34 UTC
ah ha .. secret magic .. had to be. 

regardless .. difficult to do that when : 

$ svn checkout https://svn.apache.org/repos/asf/httpd/httpd/trunk httpd-trunk
svn: E170013: Unable to connect to a repository at URL 'https://svn.apache.org/repos/asf/httpd/httpd/trunk'
svn: E000110: Error running context: Connection timed out
Comment 7 Dennis Clarke 2018-06-01 03:31:38 UTC
Seem to be making progres here however : 

beta $ ls -lapb /usr/local/bin/apr-1-config /usr/local/bin/apu-1-config
-rwxr-xr-x   1 root     root        7069 Jun  1 02:09 /usr/local/bin/apr-1-config
-rwxr-xr-x   1 root     root        6252 Jun  1 02:58 /usr/local/bin/apu-1-config
beta $ 

beta $ ./buildconf --with-apr=/usr/local/bin/apr-1-config 2>&1 | tee ../httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001.buildconf.
log 
testing apr-config executable: /usr/local/bin/apr-1-config
using apr-config version 1.6.3
copying build files
cp: cannot access /usr/local/build-1/find_apu.m4
rebuilding include/ap_config_auto.h.in
rebuilding configure
rebuilding rpm spec file
fixing timestamps for ap_expr sources
beta $ 


The file find_apu.m4 actually exists in the source tree dir for apr-util-1.6.1
which was built and tested and installed fine .. however buildconf seems to
want to go hunting in the apr-util source tree ? 

The buildconf script says : 

Usage: $0 [OPTION]...

Configuration:
  -h, --help               display this help and exit

  --with-apr=SRCDIR        define a space-separated list of directories to
                           search for the APR source code. If, instead of a
                           directory, an apr-config executable name is passed,
                           APR-Config Mode is enabled (see below). Defaults to
                           "srclib/apr ../apr"
  --with-apr-util=SRCDIR   define a space-separated list of directories to
                           search for the APR-util source code. Defaults to the
                           same location as the --with-apr SRCDIR, but with
                           "apr" replaced with "apr-util" or "aprutil". Ignored
                           in APR-Config Mode.


So I would think that --with-apr=/usr/local/bin/apr-1-config now means we are
in "APR-Config Mode" and not need --with-apr-util at all.

This isn't clear really ... if I need fresh untouched sources for both apr
and apr-util available ( however they are both built and installed fine ) then
should they be inside the httpd-trunk source tree ?  Feels sort of similar
to bootstrapping gcc wherein we need sources for libgmp, libmpfr and libmpc etc
 etc all inside the source tree regardless if you have them installed or not.

Just looking for a pointer here as I flail forwards with a new httpd that maybe
just maybe supports TLS 1.3.
Comment 8 Dennis Clarke 2018-06-01 03:55:16 UTC
Also, minor nit, configure could not find pcre-config script in the
/usr/local/bin directory despite --with-pcre=/usr/local so the 
hack seems to be to set PCRE_CONFIG=/usr/local/bin/pcre-config which
allows configure to continue.
Comment 9 Dennis Clarke 2018-06-01 04:00:13 UTC
Well this whole process fell apart fast with the compiler saying : 

beta $ /usr/local/bin/gmake
Making all in srclib
gmake[1]: Entering directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/srclib'
gmake[1]: Leaving directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/srclib'
Making all in os
gmake[1]: Entering directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os'
Making all in unix
gmake[2]: Entering directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os/unix'
gmake[3]: Entering directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os/unix'
/usr/local/build-1/libtool --silent --mode=compile /opt/developerstudio12.6/bin/cc -D_STDC_C99=    -Xa -g -errfmt=error -erroff=%none -xmemalign=8s -errshort=full -xstrconst -xildoff -m64 -xnolibmil -xcode=pic32 -xregs=no%appl -xlibmieee -ftrap=%none -xarch=sparc -mc -xs -xbuiltin=%none -xdebugformat=dwarf -xunroll=1 -D_TS_ERRNO -D_POSIX_PTHREAD_SEMANTICS -D_LARGEFILE64_SOURCE    -DSOLARIS2=10 -D_REENTRANT  -I/usr/local/include -D_POSIX_PTHREAD_SEMANTICS -D_LARGEFILE64_SOURCE -D_TS_ERRNO   -I. -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os/unix -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/include -I/usr/local/include/apr-1 -I/usr/local/include -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/aaa -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/cache -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/core -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/database -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/filters -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/ldap -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/server -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/loggers -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/lua -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/proxy -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/http2 -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/session -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/ssl -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/test -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/server -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/md -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/arch/unix -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/dav/main -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/generators -I/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/modules/mappers  -prefer-non-pic -static -c unixd.c -o unixd.lo
"unixd.c", line 326: error: undefined struct/union member: use_specific_errors
"unixd.c", line 326: warning: implicit function declaration: ap_accept_error_is_nonfatal
cc: acomp failed for unixd.c
gmake[3]: *** [/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/build/rules.mk:207: unixd.lo] Error 1
gmake[3]: Leaving directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os/unix'
gmake[2]: *** [/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/build/rules.mk:75: all-recursive] Error 1
gmake[2]: Leaving directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os/unix'
gmake[1]: *** [/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/build/rules.mk:75: all-recursive] Error 1
gmake[1]: Leaving directory '/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/os'
gmake: *** [/usr/local/build/httpd-trunk_rev_1832649_SunOS5.10_sparc64vii+.001/build/rules.mk:75: all-recursive] Error 1
beta $ 

A quick diff from a previous build that works : 

beta $ diff ../httpd-2.4.rev_1832414_SunOS5.10_sparc64vii+.001/os/unix/unixd.c ./os/unix/unixd.c
20a21
> #include "http_core.h"
26a28
> #include "apr_signal.h"
183c185
<     if(apr_procattr_cmdtype_set(attr, APR_PROGRAM) != APR_SUCCESS) {
---
>     if (apr_procattr_cmdtype_set(attr, APR_PROGRAM) != APR_SUCCESS) {
321a324,329
>   
>     /* Let the caller handle slightly more varied return values */
>     if (lr->use_specific_errors && ap_accept_error_is_nonfatal(status)) { 
>         return status;
>     }
> 
510a519,525
> static void ap_terminate(void)
> {
>     ap_main_state = AP_SQ_MS_EXITING;
>     apr_pool_destroy(ap_pglobal);
>     apr_terminate();
> }
> 
519a535,544
>     else if (!ap_retained_data_get("ap_unixd_mpm_one_process_cleanup")) {
>         /* In one process mode (debug), httpd will exit immediately when asked
>          * to (SIGTERM/SIGINT) and never restart. We still want the cleanups to
>          * run though (such that e.g. temporary files/IPCs don't leak on the
>          * system), so the first time around we use atexit() to cleanup after
>          * ourselves.
>          */
>         ap_retained_data_create("ap_unixd_mpm_one_process_cleanup", 1);
>         atexit(ap_terminate);
>     }
beta $ 

So I will peck around and see what the issue is here.
Comment 10 Dennis Clarke 2018-06-01 04:55:43 UTC
Ignore that previous comment :-\

The 2.4.33 installed   /usr/local/include/ap_listen.h was being found first ...
Comment 11 Dennis Clarke 2018-06-01 05:23:48 UTC
okay .. trunk builds : 

beta # /usr/local/bin/httpd -V 
Server version: Apache/2.5.1-dev (Unix)
Server built:   Jun  1 2018 04:55:41
Server's Module Magic Number: 20180422:1
Server loaded:  APR 1.6.3, APR-UTIL 1.5.3, PCRE 8.40 2017-01-11
Compiled using: APR 1.6.3, APR-UTIL 1.5.3, PCRE 8.40 2017-01-11
Architecture:   64-bit
Server MPM:     event
  threaded:     yes (fixed thread count)
    forked:     yes (variable process count)
Server compiled with....
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_PROC_PTHREAD_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=256
 -D HTTPD_ROOT="/usr/local"
 -D SUEXEC_BIN="/usr/local/bin/suexec"
 -D DEFAULT_PIDLOG="httpd.pid"
 -D DEFAULT_SCOREBOARD="apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="www/conf/mime.types"
 -D SERVER_CONFIG_FILE="www/conf/httpd.conf"
Comment 12 Dennis Clarke 2018-06-01 05:59:23 UTC
OKay .. server is running and seems to support TLS v1.3 with a test from
the openssl s_client thus : 

tls13 $ /usr/local/bin/openssl s_client -connect beta.tls13.net:443 -debug -state -tls1_3
CONNECTED(00000003)
SSL_connect:before SSL initialization
write to 0x100851c00 [0x1008530b0] (238 bytes => 238 (0xEE))
0000 - 16 03 01 00 e9 01 00 00-e5 03 03 6f 37 f3 07 e9   ...........o7...
0010 - 32 c8 7f 52 65 dd 36 de-e7 ad 12 9d 9c 8f 1f b5   2..Re.6.........
.
.
. etc etc 
.
.
.

SSL_connect:TLSv1.3 read encrypted extensions
depth=1 C = US, O = Let's Encrypt, CN = Let's Encrypt Authority X3
verify error:num=20:unable to get local issuer certificate
read from 0x100851c00 [0x1008aab63] (5 bytes => 5 (0x5))
0000 - 17 03 03 01 19                                    .....
read from 0x100851c00 [0x1008aab68] (281 bytes => 281 (0x119))
.
.
.
SSL_connect:TLSv1.3 read server certificate verify
.
.
.
-----END CERTIFICATE-----
subject=CN = *.tls13.net

issuer=C = US, O = Let's Encrypt, CN = Let's Encrypt Authority X3

---
No client certificate CA names sent
Peer signing digest: SHA256
Peer signature type: RSA-PSS
Server Temp Key: X25519, 253 bits
---
SSL handshake has read 3281 bytes and written 318 bytes
Verification error: unable to get local issuer certificate
---
New, TLSv1.3, Cipher is TLS_AES_256_GCM_SHA384
Server public key is 2048 bit
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
Early data was not sent
SSL-Session:
    Protocol  : TLSv1.3
    Cipher    : TLS_AES_256_GCM_SHA384
    Session-ID: 
    Session-ID-ctx: 
    Master-Key: C1EA188089C8453F4C8D0C7EA5A43A48E70645B541F165D79A2D5FDB0DAB73057CF7D06344B5E864E456D71957867922
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1527832235
    Timeout   : 7200 (sec)
    Verify return code: 20 (unable to get local issuer certificate)
    Extended master secret: no
---
read from 0x100851c00 [0x1008aab63] (5 bytes => 0 (0x0))
read:errno=0
write to 0x100851c00 [0x1008aecc3] (24 bytes => 24 (0x18))
0000 - 17 03 03 00 13 21 31 4f-bf e6 5c 3a f9 97 80 9d   .....!1O..\:....
0010 - cd 9f f7 4f 18 d8 6b d4-                          ...O..k.
SSL3 alert write:warning:close notify
read from 0x100851c00 [0x100845940] (8192 bytes => 0 (0x0))
tls13 $ 

That all looks correct except for the "unable to get local issuer certificate"


The Apache 2.5.1 server ssl logs claim : 

beta # grep "\.201" ssl_error_log
[Fri Jun 01 05:50:35.464787 2018] [ssl:info] [pid 29510:tid 27] [client 68.179.116.201:40912] AH01964: Connection to child 88 established (server beta.tls13.net:443)
[Fri Jun 01 05:50:35.465720 2018] [ssl:debug] [pid 29510:tid 27] ssl_engine_kernel.c(2297): [client 68.179.116.201:40912] AH02043: SSL virtual host for servername beta.tls13.net found
[Fri Jun 01 05:50:35.501553 2018] [ssl:debug] [pid 29510:tid 27] ssl_engine_kernel.c(2222): [client 68.179.116.201:40912] AH02041: Protocol: TLSv1.3, Cipher: TLS_AES_256_GCM_SHA384 (256/256 bits)
[Fri Jun 01 05:50:35.501610 2018] [ssl:error] [pid 29510:tid 27] [client 68.179.116.201:40912] AH02042: rejecting client initiated renegotiation
[Fri Jun 01 05:50:35.502045 2018] [ssl:debug] [pid 29510:tid 27] ssl_engine_io.c(1400): (130)Software caused connection abort: [client 68.179.116.201:40912] AH02007: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!]
[Fri Jun 01 05:50:35.502320 2018] [ssl:info] [pid 29510:tid 27] [client 68.179.116.201:40912] AH01998: Connection closed to child 88 with abortive shutdown (server beta.tls13.net:443)
beta # 
beta # /usr/local/bin/openssl ciphers -V -s -tls1_3
          0x13,0x02 - TLS_AES_256_GCM_SHA384  TLSv1.3 Kx=any      Au=any  Enc=AESGCM(256) Mac=AEAD
          0x13,0x03 - TLS_CHACHA20_POLY1305_SHA256 TLSv1.3 Kx=any      Au=any  Enc=CHACHA20/POLY1305(256) Mac=AEAD
          0x13,0x01 - TLS_AES_128_GCM_SHA256  TLSv1.3 Kx=any      Au=any  Enc=AESGCM(128) Mac=AEAD
beta # 

That looks correct .. however I have yet to get a beta/nightly Mozilla browser
to connect.
Comment 13 Dennis Clarke 2018-06-19 19:11:43 UTC
Seems solved to me given that httpd-trunk is running fine with 
TLS v1.3 and a few nits. 

see https://bz.apache.org/bugzilla/show_bug.cgi?id=62413