Bug 62437 - Configurable strict validation on provided host name and port for Host Header
Summary: Configurable strict validation on provided host name and port for Host Header
Status: RESOLVED DUPLICATE of bug 62371
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.5.31
Hardware: PC Mac OS X 10.1
: P2 enhancement (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-07 08:43 UTC by andresgseijas
Modified: 2018-06-07 08:45 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andresgseijas 2018-06-07 08:43:28 UTC
Since 8.5.31 (dunno about other tomcat versions) the hostname in Host http header is validated strictly.
This made the server to reject requests made to servers which dns addresses were using non compliant FQDN in our infrastructure. Like: `my-tomcat-server.non-prod` (the hyphen on the TLD makes the validation fail)

Could be a nice addition to have this validation disabled.
Comment 1 Mark Thomas 2018-06-07 08:45:11 UTC
The quoted FQDN is specification compliant and Tomcat will allow it from 8.5.32 onwards.

*** This bug has been marked as a duplicate of bug 62371 ***