Bug 62562 - Provide an option "unbindOnShutdown" like "bindOnInit" for Connector
Summary: Provide an option "unbindOnShutdown" like "bindOnInit" for Connector
Status: RESOLVED DUPLICATE of bug 62515
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.5.x-trunk
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 07:56 UTC by quaff
Modified: 2018-07-23 08:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quaff 2018-07-23 07:56:22 UTC
New request will block until all ServletContexts closed then destroy ProtocolHandler and failed finally while shutting down. I think it's more desirable to reject new request as quick as possible, tomcat should destroy ProtocolHandler before close ServletContext, at least provide an option like "bindOnInit=false" which reject request during start.
Comment 1 Mark Thomas 2018-07-23 08:05:21 UTC

*** This bug has been marked as a duplicate of bug 62515 ***