Bug 62644 - Apache httpd hangs after a few days on Solaris i386
Summary: Apache httpd hangs after a few days on Solaris i386
Status: RESOLVED DUPLICATE of bug 61786
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.4.34
Hardware: Sun Solaris
: P2 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-21 08:48 UTC by pns3pns
Modified: 2018-08-22 02:08 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pns3pns 2018-08-21 08:48:54 UTC
Apache httpd processes are there, just not accepting requests.
Comment 1 pns3pns 2018-08-21 08:50:00 UTC
$ uname -a
SunOS HKFON013WSSTA01 5.11 11.3 i86pc i386 i86pc Solaris


$ ldd bin/httpd
        libpcre.so.1 =>  /usr/local/pcre-8.40/lib/libpcre.so.1
        libaprutil-1.so.0 =>     /u01/homes/swsdev/httpd_Iws-2.4.34/srclib/apr-util/lib/libaprutil-1.so.0
        libexpat.so.1 =>         /usr/lib/64/libexpat.so.1
        libapr-1.so.0 =>         /u01/homes/swsdev/httpd_Iws-2.4.34/srclib/apr/lib/libapr-1.so.0
        libuuid.so.1 =>  /lib/64/libuuid.so.1
        libsendfile.so.1 =>      /lib/64/libsendfile.so.1
        libsocket.so.1 =>        /lib/64/libsocket.so.1
        libnsl.so.1 =>   /lib/64/libnsl.so.1
        libpthread.so.1 =>       /lib/64/libpthread.so.1
        libc.so.1 =>     /lib/64/libc.so.1
        libgcc_s.so.1 =>         /usr/lib/64/libgcc_s.so.1
        libmp.so.2 =>    /lib/64/libmp.so.2
        libucrypto.so.1 =>       /lib/64/libucrypto.so.1
        libelf.so.1 =>   /lib/64/libelf.so.1
        libcryptoutil.so.1 =>    /lib/64/libcryptoutil.so.1
        libz.so.1 =>     /lib/64/libz.so.1
Comment 2 Eric Covener 2018-08-21 10:35:49 UTC

*** This bug has been marked as a duplicate of bug 61786 ***
Comment 3 pns3pns 2018-08-22 02:08:13 UTC
So, this bug has been fixed in APR 1.6.4, which is not yet under General Availability. Is there any schedule when 1.6.4 will be released as a recommended and stable version? 
Thank you.