Bug 62661 - Jmeter report generator doesn't work when need generate report after test
Summary: Jmeter report generator doesn't work when need generate report after test
Status: RESOLVED DUPLICATE of bug 62243
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-30 10:39 UTC by Andrei M. Kornienko
Modified: 2018-09-01 14:04 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei M. Kornienko 2018-08-30 10:39:40 UTC
As said in documentation:
jmeter -n -t <test JMX file> -l <test log file> -e -o <Path to output folder>

This comand must make report for me AFTER test.

I did:

C:\Users\User\Desktop\apache-jmeter-4.0\bin>jmeter -n -t 600-stab.jmx -l
 stabl.jtl -e -o test

And I get message:

Creating summariser <summary>
Error in NonGUIDriver java.lang.IllegalArgumentException: Results file:stabl.jtl
 is not empty
Comment 1 Philippe Mouawad 2018-09-01 13:45:57 UTC
Hello,
As per message, JMeter tells you that stabl.jtl and refuses to overwrite it.

In next version 5.0, an additional parameter --forceDeleteResultFile has been introduced for such cases.

You can use nightly build to see this behaviour as we are close to a release.

Regards

*** This bug has been marked as a duplicate of bug 62243 ***
Comment 2 Andrei M. Kornienko 2018-09-01 13:59:53 UTC
Good joke.
I thought that this comand must create an html report using existing log file. Like I did.
Sorry about it.
But, can I generate html report from existing log file?
Thanks, Andrei.
Comment 3 Philippe Mouawad 2018-09-01 14:04:39 UTC
(In reply to Andrei M. Kornienko from comment #2)
> Good joke.
> I thought that this comand must create an html report using existing log
> file. Like I did.
> Sorry about it.
> But, can I generate html report from existing log file?
> Thanks, Andrei.

Ok in this case you misread documentation and should be using :

- https://jmeter.apache.org/usermanual/generating-dashboard.html#report_only


The command you're using RUNS THE TEST and GENERATES REPORT after end of test.

Regards