Bug 62770 - Aggregate Graph throws ArrayIndexOutOfBoundsException
Summary: Aggregate Graph throws ArrayIndexOutOfBoundsException
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.0
Hardware: All All
: P2 regression (vote)
Target Milestone: JMETER_5.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 62896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-28 14:47 UTC by cuh
Modified: 2019-02-06 06:02 UTC (History)
3 users (show)



Attachments
jmeter log file (12.95 KB, text/plain)
2018-09-28 14:47 UTC, cuh
Details
test plan with Sample Debugger (3.64 KB, application/xml)
2018-09-28 14:48 UTC, cuh
Details
jmeter log file, error tested on r1852962 (5.07 KB, text/plain)
2019-02-05 14:05 UTC, Natalia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cuh 2018-09-28 14:47:09 UTC
Created attachment 36171 [details]
jmeter log file

Since JMeter 5 the aggregrate functionality is not working any more.
I checked it with JMeter 4.0. There the aggregate report/graph works. 

I could reproduce it with a Sample Debugger.


*Steps to reproduce*
Configure a Thread Group with a Debug Sample.
Add Aggregate Report as Listener.
Run the Test Plan

the following WARN can be found in the log files.
=> WARN o.a.j.u.JMeterUtils: ERROR! Resource string not found: [...]

see attached log file.

Using the Aggregate Graph will end up in an exception (also in attached log file) and no graph will be displayed:
ERROR o.a.j.JMeter: Uncaught exception: 
java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.ArrayList.elementData(ArrayList.java:422) ~[?:1.8.0_181]
	at java.util.ArrayList.get(ArrayList.java:435) ~[?:1.8.0_181]
	at org.apache.jorphan.gui.ObjectTableModel.getValueAt(ObjectTableModel.java:187) ~[jorphan.jar:5.0 r1840935]
	at org.apache.jmeter.visualizers.StatGraphVisualizer.getData(StatGraphVisualizer.java:638) ~[ApacheJMeter_components.jar:5.0 r1840935]
	at org.apache.jmeter.visualizers.StatGraphVisualizer.makeGraph(StatGraphVisualizer.java:594) ~[ApacheJMeter_components.jar:5.0 r1840935]
	at org.apache.jmeter.visualizers.StatGraphVisualizer.actionMakeGraph(StatGraphVisualizer.java:790) ~[ApacheJMeter_components.jar:5.0 r1840935]
	at org.apache.jmeter.visualizers.StatGraphVisualizer.actionPerformed(StatGraphVisualizer.java:702) ~[ApacheJMeter_components.jar:5.0 r1840935]
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022) ~[?:1.8.0_181]
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348) ~[?:1.8.0_181]
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402) ~[?:1.8.0_181]
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259) ~[?:1.8.0_181]
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252) ~[?:1.8.0_181]
	at java.awt.Component.processMouseEvent(Component.java:6539) ~[?:1.8.0_181]
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324) ~[?:1.8.0_181]
	at java.awt.Component.processEvent(Component.java:6304) ~[?:1.8.0_181]
	at java.awt.Container.processEvent(Container.java:2239) ~[?:1.8.0_181]
	at java.awt.Component.dispatchEventImpl(Component.java:4889) ~[?:1.8.0_181]
	at java.awt.Container.dispatchEventImpl(Container.java:2297) ~[?:1.8.0_181]
	at java.awt.Component.dispatchEvent(Component.java:4711) ~[?:1.8.0_181]
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904) ~[?:1.8.0_181]
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535) ~[?:1.8.0_181]
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476) ~[?:1.8.0_181]
	at java.awt.Container.dispatchEventImpl(Container.java:2283) ~[?:1.8.0_181]
	at java.awt.Window.dispatchEventImpl(Window.java:2746) ~[?:1.8.0_181]
	at java.awt.Component.dispatchEvent(Component.java:4711) ~[?:1.8.0_181]
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760) ~[?:1.8.0_181]
	at java.awt.EventQueue.access$500(EventQueue.java:97) ~[?:1.8.0_181]
	at java.awt.EventQueue$3.run(EventQueue.java:709) ~[?:1.8.0_181]
	at java.awt.EventQueue$3.run(EventQueue.java:703) ~[?:1.8.0_181]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_181]
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74) ~[?:1.8.0_181]
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84) ~[?:1.8.0_181]
	at java.awt.EventQueue$4.run(EventQueue.java:733) ~[?:1.8.0_181]
	at java.awt.EventQueue$4.run(EventQueue.java:731) ~[?:1.8.0_181]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_181]
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74) ~[?:1.8.0_181]
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730) ~[?:1.8.0_181]
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205) [?:1.8.0_181]
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116) [?:1.8.0_181]
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105) [?:1.8.0_181]
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101) [?:1.8.0_181]
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93) [?:1.8.0_181]
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82) [?:1.8.0_181]
Comment 1 cuh 2018-09-28 14:48:02 UTC
Created attachment 36172 [details]
test plan with Sample Debugger
Comment 2 Philippe Mouawad 2018-09-30 19:31:40 UTC
Issue has been introduced by :

- http://svn.apache.org/viewvc?rev=1834634&view=rev
Comment 3 Philippe Mouawad 2018-09-30 19:32:07 UTC
(In reply to Philippe Mouawad from comment #2)
> Issue has been introduced by :
> 
> - http://svn.apache.org/viewvc?rev=1834634&view=rev

It's related to Bug 60705
Comment 4 Philippe Mouawad 2018-09-30 19:50:37 UTC
pmouawad@apache.org
	
9:50 PM (0 minutes ago)
	
to commits
Author: pmouawad
Date: Sun Sep 30 19:50:23 2018
New Revision: 1842408

URL: http://svn.apache.org/viewvc?rev=1842408&view=rev
Log:
Bug 62770 : Aggregate Graph throws ArrayIndexOutOfBoundsException
Bugzilla Id: 62770

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/StatGraphVisualizer.java
    jmeter/trunk/src/core/org/apache/jmeter/util/JMeterUtils.java
    jmeter/trunk/xdocs/changes.xml
Comment 5 Philippe Mouawad 2018-09-30 19:51:22 UTC
Thanks for report.

Fix will be available in 5.1 version.
Meanwhile if you can test tomorrow the nightly build and confirm bug is fixed, it will be very nice of you.

Thanks
Comment 6 Philippe Mouawad 2018-11-10 11:04:51 UTC
*** Bug 62896 has been marked as a duplicate of this bug. ***
Comment 7 Natalia 2019-02-04 06:32:45 UTC
Hi all,

Could you please advise if there's a workaround for this bug?

And, also, where is it possible to test on new build, which contains a fix?

Thanks!
Comment 8 Philippe Mouawad 2019-02-04 06:41:25 UTC
(In reply to Natalia from comment #7)
> Hi all,
> 
> Could you please advise if there's a workaround for this bug?
> 
> And, also, where is it possible to test on new build, which contains a fix?
> 
> Thanks!

No workaround.
You can use nightly build which is close to release.

https://ci.apache.org/projects/jmeter/nightlies/
Comment 9 Natalia 2019-02-05 14:02:00 UTC
Thank you! 

I've uploaded a latest jmeter test version, where bug is supposed to be fixed.
And tried to open the file in aggregate report template.
But there's still an error there.
Comment 10 Natalia 2019-02-05 14:05:11 UTC
Created attachment 36422 [details]
jmeter log file, error tested on r1852962
Comment 11 Philippe Mouawad 2019-02-05 14:12:47 UTC
(In reply to Natalia from comment #10)
> Created attachment 36422 [details]
> jmeter log file, error tested on r1852962

Hello Natalia,
The stacktrace you show has no relation with this bug report.

Can you create a new issue and attach:

- your test plan if possible, otherwise try to remove as much as possible provided you still reproduce issue, or send it privately to me
- jmeter.log


Thanks
Comment 12 Natalia 2019-02-06 06:02:52 UTC
Thank you Philippe!
I've created a separate ticket: id=63148