Bug 62829 - Allow specifying Proxy server scheme for HTTP request sampler, Advanced tab and command line option
Summary: Allow specifying Proxy server scheme for HTTP request sampler, Advanced tab a...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 63179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-16 07:02 UTC by Hitesh Patel
Modified: 2019-02-15 06:18 UTC (History)
2 users (show)



Attachments
Example of what needs to be added (133.08 KB, image/png)
2018-10-27 19:54 UTC, Hitesh Patel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hitesh Patel 2018-10-16 07:02:52 UTC
On HTTP request sampler, advanced tab, proxy server information like IP/hostname and port can be specified, but there is no place to specify the protocol to use. Proxy server could be using https but there is no way to specify to use that protocol for the proxy.

There needs to be a new field added to allow putting in protocol value and make use of it for making the request.
Comment 1 Philippe Mouawad 2018-10-27 13:24:05 UTC
Can you provide an example of the expected configuration ?
Thank you
Comment 2 Hitesh Patel 2018-10-27 19:54:40 UTC
Created attachment 36219 [details]
Example of what needs to be added

Image of what http request default should look like. http request sampler would be similar.

I have a patch which I will submit soon.
Comment 3 Hitesh Patel 2018-10-27 22:21:53 UTC
Submitted pull request: https://github.com/apache/jmeter/pull/413
Comment 4 Philippe Mouawad 2018-10-28 09:59:17 UTC
Thanks for the PR.
Comment 5 Philippe Mouawad 2018-11-18 21:16:48 UTC
Author: pmouawad
Date: Sun Nov 18 21:16:17 2018
New Revision: 1846866

URL: http://svn.apache.org/viewvc?rev=1846866&view=rev
Log:
Bug 62829 - Allow specifying Proxy server scheme for HTTP request sampler, Advanced tab and command line option

This closes #413
Contributed by Hitesh Patel
Bugzilla Id: 62829

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/config/gui/HttpDefaultsGui.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/gui/HttpTestSampleGui.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPAbstractImpl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHCAbstractImpl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/get-started.xml
Comment 6 Philippe Mouawad 2018-11-18 21:17:29 UTC
Thanks for contribution.

Can you please test nightly build once it is available with and without scheme to ensure there is not issue ?

Thank you.
Comment 7 Hitesh Patel 2018-11-19 02:01:55 UTC
(In reply to Philippe Mouawad from comment #6)
> Thanks for contribution.
> 
> Can you please test nightly build once it is available with and without
> scheme to ensure there is not issue ?
> 
> Thank you.

From https://builds.apache.org/job/JMeter-trunk/6971/, downloaded apache-jmeter-r1846867.zip
Unzipped apache-jmeter-r1846867.zip

Ran one of our work performance tests with apache-jmeter-r1846867/bin/jmeter --proxyHost internal.proxyHost --proxyPort 1234 --proxyScheme https ...
from GUI and command line. Verified test ran successfully as expected.

Ran the same test without any proxy host/port/scheme information, on command line, with running test via GUI and command line. Test run failed as expected.
Comment 8 Felix Schumacher 2019-02-15 06:18:17 UTC
*** Bug 63179 has been marked as a duplicate of this bug. ***