Bug 62932 - bug in function proxy_wstunnel_canon preventing functionality of websocket proxy over Unix Domain Sockets
Summary: bug in function proxy_wstunnel_canon preventing functionality of websocket pr...
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy_wstunnel (show other bugs)
Version: 2.4-HEAD
Hardware: All Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk, PatchAvailable
Depends on:
Blocks:
 
Reported: 2018-11-21 11:02 UTC by pavel
Modified: 2019-02-15 15:58 UTC (History)
1 user (show)



Attachments
patch for modules/proxy/mod_proxy_wstunnel.c (759 bytes, patch)
2018-11-21 11:02 UTC, pavel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pavel 2018-11-21 11:02:10 UTC
Created attachment 36271 [details]
patch for modules/proxy/mod_proxy_wstunnel.c

configuration example:
<Location "/apis">
ProxyPass unix:/var/run/unix.sock|ws://127.0.0.1/api
</Location>

currently ap_proxy_get_worker can't get matched pre-defined worker because of different uri formatting in proxy_wstunnel_canon and ap_proxy_define_worker

from additionally added logs i see what ap_proxy_get_worker has failed to match

ws://127.0.0.1:80/api/router/proxy AND ws://127.0.0.1/api
and fallback to default (*) proxy worker (which does work because nothing know about UDS path)

imho this patch should be pushed to trunk also
Comment 1 pavel 2019-01-11 18:18:03 UTC
do you need additional information ? can i assist to reproduce this issue ?
Comment 2 Christophe JAILLET 2019-01-11 19:37:17 UTC
Thx for the report and for the reminder.

Committed in trunk in r1851093.
Comment 3 Christophe JAILLET 2019-01-11 20:10:17 UTC
Proposed for backport in r1851096
Comment 4 Christophe JAILLET 2019-02-15 15:58:52 UTC
Backported in 2.4.x in r1853653.

Will be part of 2.4.39