Bug 62970 - HTML report to become very accessible and usable to many Jmeter users
Summary: HTML report to become very accessible and usable to many Jmeter users
Status: RESOLVED DUPLICATE of bug 59896
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.0
Hardware: All All
: P2 enhancement with 1 vote (vote)
Target Milestone: JMETER_5.1.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2018-12-01 12:31 UTC by Shay Ginsbourg
Modified: 2019-03-02 20:20 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shay Ginsbourg 2018-12-01 12:31:56 UTC
Recently, Jmeter has incredibly improved in so many aspects that its developers really deserve some standing ovation. It is justifiably considered to be a leading testing tool. Minor usability changes that impose little risk could make it even greater. For example, the HTML report is a wonderful and most valuable feature that unfortunately does not have a GUI for its own generation. Even the simplest GUI would make it accessible for new users. Another related and common issue is that many JTL files has a last line which is incomplete for various reasons. The HTML report may not be created at all for such a frequent JTL file issue, so it would be very wise to automatically ignore last lines in cases of their incompleteness. Thank you guys for your good work and please accept my compliments. 

philippe.mouawad@gmail.com via jmeter.apache.org 
Tue, Nov 27, 10:14 PM
to JMeter

Thank you Shay !
All these rather rarely expressed kind words are really very nice from you
and indeed encourage us.

Your ideas are interesting:

   - I think there is an enhancement bugzilla for the GUI one but our time
   is counted
   - Please open a bugzilla for the second one:
      - Explanation is that output is buffered so we end up  with partial
      lines while load testing. At end the file is complete.
      - But I agree it should be possible to generate the report ignoring
      last line if incomplete


One last thing regarding the wonderful HTML report is that unless it can be exported to a standard PDF document, there are no customers that are willing to accept it, since it may not be delivered as a single file via e-mail. (Zipping the HTML folder is not an option, since zip files are blocked by the mailing system due to security considerations.)
Comment 1 Shay Ginsbourg 2018-12-01 12:40:13 UTC
All requests are low risk. None can cause regression to JMETER.
Comment 2 Philippe Mouawad 2019-03-02 20:20:25 UTC

*** This bug has been marked as a duplicate of bug 59896 ***