Bug 63099 - Regression in JMeter 5.0 due to fix of Bug 62478
Summary: Regression in JMeter 5.0 due to fix of Bug 62478
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.0
Hardware: All All
: P2 minor (vote)
Target Milestone: JMETER_5.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2019-01-22 19:49 UTC by Felix Schumacher
Modified: 2019-01-22 20:57 UTC (History)
0 users



Attachments
Escape commata that are outside of variable replacement structures, only (3.04 KB, patch)
2019-01-22 19:49 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Schumacher 2019-01-22 19:49:09 UTC
Created attachment 36386 [details]
Escape commata that are outside of variable replacement structures, only

We have a bug report considered as regression on jmeter-fr google group :
- https://groups.google.com/forum/#!topic/jmeter-fr/es1ikcAxsDE

In summary previously when using function composition in Function Helper
Dialog:

Use "__urlencode" as the function and "${__time(dd/MM/yyyy,NEWVAR)}" as the argument, then instead of:

  ${__urlencode(${__time(dd/MM/yyyy,NEWVAR)})}

the helper generates (notice '\,' instead of ','):

  ${__urlencode(${__time(dd/MM/yyyy\,NEWVAR)})}

Issue is due to another bug fix 62478:
Comment 1 Felix Schumacher 2019-01-22 19:55:05 UTC
Fix will be included in version 5.1

Date: Tue Jan 22 19:53:45 2019
New Revision: 1851858

URL: http://svn.apache.org/viewvc?rev=1851858&view=rev
Log:
Escape commata in function helper dialog only outside of variable replacement structures.

Bugzilla Id: 63099

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/functions/gui/FunctionHelper.java
    jmeter/trunk/test/src/org/apache/jmeter/functions/gui/FunctionHelperSpec.groovy
    jmeter/trunk/xdocs/changes.xml
Comment 2 Felix Schumacher 2019-01-22 20:57:29 UTC
Date: Tue Jan 22 20:56:10 2019
New Revision: 1851864

URL: http://svn.apache.org/viewvc?rev=1851864&view=rev
Log:
Escape commata in function helper dialog only outside of variable replacement structures.

Correct detection of an escaped $ and fix checkstyle error, while we are here.

Bugzilla Id: 63099

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/functions/gui/FunctionHelper.java
    jmeter/trunk/test/src/org/apache/jmeter/functions/gui/FunctionHelperSpec.groovy