Bug 63144 - View listener tree take a long time to open response that have Huge text
Summary: View listener tree take a long time to open response that have Huge text
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 60816 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-05 07:47 UTC by Ahmad
Modified: 2019-02-10 21:44 UTC (History)
1 user (show)



Attachments
This image illustrate the slowness on open response (156.50 KB, image/gif)
2019-02-05 07:47 UTC, Ahmad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad 2019-02-05 07:47:32 UTC
Created attachment 36421 [details]
This image illustrate the slowness on open response

I have a problem with JMeter when I want to see the response using view result tress, if the response has a huge text (essentially JSON) I wait about 1 minute to open this response.

see the attachment.
Comment 1 Philippe Mouawad 2019-02-05 09:28:18 UTC
Hello,
The gif does not show something obvious.

Is your JSON code without any space ?
If so, it's a known issue due to a JDK bug:

View Results Tree may freeze rendering large response particularly if this response has no spaces, see Bug 60816. This is due to an identified Java Bug UI stuck when calling JEditorPane.setText() or JTextArea.setText() with long text without space. 

If it's not the case, please show the request so that we're able to reproduce.
Comment 2 Philippe Mouawad 2019-02-07 11:47:10 UTC
Author: pmouawad
Date: Thu Feb  7 11:24:15 2019
New Revision: 1853121

URL: http://svn.apache.org/viewvc?rev=1853121&view=rev
Log:
Bug 63144 - View listener tree take a long time to open response that have Huge text

Contributed by UbikLoadPack
Bugzilla Id: 63144

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsDocument.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsHTMLFormatted.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsJSON.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsText.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/SamplerResultTab.java
    jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2019-02-07 11:48:42 UTC
Can you try last successful build at:

https://builds.apache.org/job/JMeter-trunk/lastSuccessfulBuild/artifact/trunk/dist/

I noticed huge gains (30s to 2/3 seconds)
Comment 4 Philippe Mouawad 2019-02-10 21:44:23 UTC
*** Bug 60816 has been marked as a duplicate of this bug. ***