Bug 63167 - Network Requirements To Resolve No Members Active In Cluster Group
Summary: Network Requirements To Resolve No Members Active In Cluster Group
Status: NEW
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 7.0.70
Hardware: PC Linux
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-12 00:00 UTC by Nacho Ganguli
Modified: 2019-02-12 10:46 UTC (History)
0 users



Attachments
server.xml for node 1 (3.88 KB, text/xml)
2019-02-12 00:00 UTC, Nacho Ganguli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nacho Ganguli 2019-02-12 00:00:29 UTC
Created attachment 36433 [details]
server.xml for node 1

Trying to find a solution to "no members active in cluster group," my observation is identical to Bug 52263.  I tried the attached server.xml from response "working static cluster config." Yet for me it continues to result in "no members active in cluster group."

Attached is my similar version of server.xml configuring a 2-node static member cluster.

(The second server.xml is identical except the receiver address IP and member host IP are swapped.)

The HOW-TO documentation could be improved to address the following:

1. If "no members active in cluster group" can be caused by a network issue, what steps are there to determine if a network is configured properly? I have created a Private LAN with internal IPs assigned to each node. I am using these IPs in the receiver and member components, but not sure if I need additional proxy configuration.

2. Explain the value of defining a localMember.

3. If a session cookie consists only of JSESSIONID, is serializing still required?

TIAD
Comment 1 Mark Thomas 2019-02-12 10:46:19 UTC
Moving to enhancement request for docs.