Bug 63207 - java.lang.NullPointerException: null when run Jmeter 5.1 with proxy options
Summary: java.lang.NullPointerException: null when run Jmeter 5.1 with proxy options
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.1
Hardware: All All
: P2 regression (vote)
Target Milestone: JMETER_5.1.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 63238 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-25 15:38 UTC by Mike Khil
Modified: 2019-03-06 14:35 UTC (History)
2 users (show)



Attachments
log (2.22 KB, text/plain)
2019-02-25 15:38 UTC, Mike Khil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Khil 2019-02-25 15:38:59 UTC
Created attachment 36459 [details]
log

Hi there !
When I start Jmeter 5.1 with proxy options like jmeter.bat -H host -P port -u login -a password jmeter failed with error level =1 and in log file information:
java.lang.NullPointerException: null
	at org.apache.jmeter.JMeter.setProxy(JMeter.java:763) ~[ApacheJMeter_core.jar:5.1 r1853635]
	at org.apache.jmeter.JMeter.start(JMeter.java:490) [ApacheJMeter_core.jar:5.1 r1853635]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_191]
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_191]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_191]
	at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_191]
	at org.apache.jmeter.NewDriver.main(NewDriver.java:253) [ApacheJMeter.jar:5.1 r1853635]
Comment 1 Philippe Mouawad 2019-02-25 15:47:42 UTC
Author: pmouawad
Date: Mon Feb 25 15:47:07 2019
New Revision: 1854317

URL: http://svn.apache.org/viewvc?rev=1854317&view=rev
Log:
Bug 63207 - java.lang.NullPointerException: null when run Jmeter 5.1 with proxy options
Bugzilla Id: 63207

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2019-02-25 15:55:06 UTC
Hello,
Can you test next CI build which is in progress (if it fails check next successful one):
https://builds.apache.org/job/JMeter-trunk/7121/

And tell if it works.

As a workaround, add to your command line:

 --proxyScheme http

or 

 --proxyScheme https

Thanks for your feedback.
Comment 3 Mike Khil 2019-02-25 16:12:18 UTC
yes/ works well in both cases. Thanks
Comment 4 Philippe Mouawad 2019-03-06 14:35:07 UTC
*** Bug 63238 has been marked as a duplicate of this bug. ***