Bug 63238 - While starting Jmeter by bypassing proxy it is returning "java.lang.NullPointerException: null"
Summary: While starting Jmeter by bypassing proxy it is returning "java.lang.NullPoint...
Status: RESOLVED DUPLICATE of bug 63207
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.1
Hardware: PC All
: P2 major (vote)
Target Milestone: JMETER_5.1.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2019-03-06 14:14 UTC by Pravin
Modified: 2019-03-06 14:35 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pravin 2019-03-06 14:14:24 UTC
Actual:- 
When Jmeter(v5.1) is started using following command by bypassing he proxy it is returning null in console. 

Jmeter start up command used to bypass proxy & opnen Jmeter:-
C:\Performance\apache-jmeter-5.1\bin>jmeter.bat -H <proxyName> -P <Port> -u <userName>

Full stack trace from Jmeter.log:- 

2019-03-05 19:31:30,482 ERROR o.a.j.JMeter: An error occurred: 
java.lang.NullPointerException: null
	at org.apache.jmeter.JMeter.setProxy(JMeter.java:763) ~[ApacheJMeter_core.jar:5.1 r1853635]
	at org.apache.jmeter.JMeter.start(JMeter.java:490) [ApacheJMeter_core.jar:5.1 r1853635]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_191]
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_191]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_191]
	at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_191]
	at org.apache.jmeter.NewDriver.main(NewDriver.java:253) [ApacheJMeter.jar:5.1 r1853635]

Output from console:- 

An error occurred: null
errorlevel=1
Press any key to continue . . .

Note:- When same command is used in Jmeter version 5.0 it is working & I am able to see jmeter GUI opening bypassing proxy server.
Comment 1 Philippe Mouawad 2019-03-06 14:35:07 UTC

*** This bug has been marked as a duplicate of bug 63207 ***