Bug 63239 - Maven Dependency issue for poi-ooxml version 4.0.1
Summary: Maven Dependency issue for poi-ooxml version 4.0.1
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: 4.0.x-dev
Hardware: Other All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2019-03-06 15:40 UTC by Sebastian Friedrich
Modified: 2019-03-20 13:17 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Friedrich 2019-03-06 15:40:33 UTC
Hey Guys, 

figured that the dependency for Maven on the poi-ooxml doesnt work at the Moment.

Source https://mvnrepository.com/artifact/org.apache.poi/poi-ooxml/4.0.1
(Failed to read artifact descriptor)

Older versions do fine with my setup. 

IDE: Eclipse 
Project via: Maven
Java-Version: JavaSE-1.8(java-8-openjdk-amd64)
Operation System: Linux 18.02 via VM

Comment 1 Dominik Stadler 2019-03-10 09:24:14 UTC
Not sure what exactly is wrong for you, but we have multiple projects which use the poi-artifacts just fine, can you provide more information, ideally a small self-sufficent project which shows your problem?
Comment 2 Sebastian Friedrich 2019-03-20 12:14:04 UTC
Hi Dominik,

i just solved the Problem. Had a hard time figuring it out so i ended up adressing it wrongly. 


Eclipse / Maven wasnt able to download the necessary files from the repository. I dont know why it was the case, neither do i know why it exclusively occured when i tried to add the latest POI but it doesnt seem to be a POI problem. 
I think it simply was a setup problem. 

Only way to fix this on my Setup, was a mvn install -U clean.

Thanks for looking into case and I'm sry for getting the wrong clue at this. 

Comment 3 Dominik Stadler 2019-03-20 13:17:39 UTC
No problem, description was good enough to not send us into the wrong direction, so not much time wasted.

This is not a problem in Apache POI, thus resolving here.