Bug 63329 - 2.4.39 broke svn and git integration
Summary: 2.4.39 broke svn and git integration
Status: RESOLVED DUPLICATE of bug 63325
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_reqtimeout (show other bugs)
Version: 2.4.39
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-09 11:01 UTC by apache-bugs.a2
Modified: 2019-04-09 14:00 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description apache-bugs.a2 2019-04-09 11:01:13 UTC
2.4.38 - works fine
2.4.39 with same config, same configure parameters, everything same, does not work with svn (mod_dav_svn) and git (git-http-backend) when comminting or pushing files larger than about ~15MB.

git returns error
error: RPC failed; HTTP 408 curl 22 The requested URL returned error: 408

svn returns error 
Commit failed (details follow):
Unexpected end of svndiff input
Comment 1 apache-bugs.a2 2019-04-09 11:35:35 UTC
I've recompiled httpd 2.4.39 with modules/filters/mod_reqtimeout.c from httpd 2.4.38 and everything works fine again. 
Problem is with mod_reqtimeout and changes done in it  httpd version 2.4.39

ps. all test were made with plain http (not https)
Comment 2 Ruediger Pluem 2019-04-09 11:46:47 UTC
Sounds like a duplicate of bug 63325. Can you please test the solution offered there?
Comment 3 apache-bugs.a2 2019-04-09 12:08:04 UTC
mod_reqtimeout.c code from revision 1857129 (https://svn.apache.org/viewvc/httpd/httpd/trunk/modules/filters/mod_reqtimeout.c?view=markup&pathrev=1857129) seems to work fine.
Comment 4 Yann Ylavic 2019-04-09 14:00:37 UTC

*** This bug has been marked as a duplicate of bug 63325 ***