Bug 63338 - Using eclipse to compile Jmeter 5.1.1 version source code, found in the compilation process, Chinese GUI garbled (item code is UTF-8)
Summary: Using eclipse to compile Jmeter 5.1.1 version source code, found in the compi...
Status: RESOLVED DUPLICATE of bug 63630
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.1.1
Hardware: All All
: P2 major (vote)
Target Milestone: JMETER_5.2
Assignee: JMeter issues mailing list
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2019-04-11 00:54 UTC by Mr-Bear
Modified: 2019-09-25 08:22 UTC (History)
1 user (show)



Attachments
Source code compilation GUI (174.71 KB, image/png)
2019-04-11 00:54 UTC, Mr-Bear
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mr-Bear 2019-04-11 00:54:14 UTC
Created attachment 36519 [details]
Source code compilation GUI

1. Official website download source
2.Use eclipse for source code compilation
3.Execution source NewDriver class, JMeter debugging page appears Chinese garbled
4.The project code is UTF-8
Comment 1 Felix Schumacher 2019-04-17 16:39:10 UTC
This is a known bug. We are hoping to get it fixed while migrating to gradle.
You can fix it locally by using "ant clean install" to translate the encoded properties.
Comment 2 Vladimir Sitnikov 2019-04-17 19:08:58 UTC
@Mr-Bear, can you please try https://github.com/apache/jmeter/pull/448 ?
Comment 3 Philippe Mouawad 2019-09-25 08:22:57 UTC
This has been fixed by Bug 63630.

*** This bug has been marked as a duplicate of bug 63630 ***