Bug 63339 - Setting cached formula result corrupts workbook
Summary: Setting cached formula result corrupts workbook
Status: RESOLVED DUPLICATE of bug 63845
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 4.0.x-dev
Hardware: PC All
: P2 regression (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 63845
Blocks:
  Show dependency tree
 
Reported: 2019-04-11 02:59 UTC by Gili
Modified: 2020-10-25 04:55 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gili 2019-04-11 02:59:27 UTC
Version 4.1.0

Bug #46885 is back. If one invokes setCellValue(String) on a cell of type FORMULA, the new value will be ignored. One can workaround this issue by explicitly changing the cell type prior to changing its value.

XSSFCell.setCellValueImpl() invokes _cell.setT(STCellType.STR) but _cell.isSetF() remains true.

Expected behavior: _cell.isSetF() should return false after changing the cell value from a FORMULA to String.
Comment 1 Dominik Stadler 2019-12-15 12:53:33 UTC
This is likely related to the regression discussed in bug 63845
Comment 2 Dominik Stadler 2020-10-25 04:55:15 UTC
As far as I could test this should be fixed via the changes for bug #63845 already, maybe you can verify a recent nightly build to verify from your end as well.

*** This bug has been marked as a duplicate of bug 63845 ***