Bug 63397 - Exception should be logged rather than having to increase log level.
Summary: Exception should be logged rather than having to increase log level.
Status: RESOLVED DUPLICATE of bug 60174
Alias: None
Product: Tomcat 9
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 9.0.19
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: -----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-02 19:18 UTC by Chris Erskine
Modified: 2019-05-13 16:24 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Erskine 2019-05-02 19:18:32 UTC
The following stack trace was logged to catalina.<date>.log only after turning on FINE logging.  The status code in the access log was logged as 200 but the value returned to the application for this was 500.  This was due to tracing the jersey transaction which loads the trace in the header.  This should have been logged with the default logging level and had reported the status as 500 in the access log.


02-May-2019 13:59:09.995 SEVERE [http-nio-8080-exec-42] org.apache.coyote.http11.Http11Processor.service Error processing request

 org.apache.coyote.http11.HeadersTooLargeException: An attempt was made to write more data to the response headers than there was room available in the buffer. Increase maxHttpHeaderSize on the connector or write less data into the response headers.

    at org.apache.coyote.http11.Http11OutputBuffer.checkLengthBeforeWrite(Http11OutputBuffer.java:458)

    at org.apache.coyote.http11.Http11OutputBuffer.write(Http11OutputBuffer.java:411)

    at org.apache.coyote.http11.Http11OutputBuffer.write(Http11OutputBuffer.java:397)

    at org.apache.coyote.http11.Http11OutputBuffer.sendHeader(Http11OutputBuffer.java:357)

    at org.apache.coyote.http11.Http11Processor.prepareResponse(Http11Processor.java:975)

    at org.apache.coyote.AbstractProcessor.action(AbstractProcessor.java:369)

    at org.apache.coyote.Response.action(Response.java:211)

    at org.apache.coyote.Response.sendHeaders(Response.java:437)

    at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:281)

    at org.apache.catalina.connector.OutputBuffer.close(OutputBuffer.java:241)

    at org.apache.catalina.connector.Response.finishResponse(Response.java:441)

    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:374)

    at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:408)

    at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)

    at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:836)

    at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1747)

    at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)

    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

    at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)

    at java.lang.Thread.run(Thread.java:748)
Comment 1 Mark Thomas 2019-05-13 16:24:31 UTC
This is already logged at ERROR level.

*** This bug has been marked as a duplicate of bug 60174 ***