Bug 63507 - Tomcat not responding (in browser) after undeploying docs and examples application.
Summary: Tomcat not responding (in browser) after undeploying docs and examples applic...
Status: RESOLVED INVALID
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.5.37
Hardware: PC Linux
: P2 critical (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 03:50 UTC by sadat
Modified: 2019-06-16 10:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sadat 2019-06-16 03:50:55 UTC
For security reasons, I wanted to remove docs and examples application. So, at first, I deleted both of their directories from the webapps directory. However, the remaining applications (including manager app) were not responding in browser (blank pages were being served), although the tomcat service was running in the server. The logs were not showing anything.

Then I put back docs and examples directories in webapps directory, and things were back again. Then, I tried to undeploy them using tomcat manager. The undeployment works, but again I got blank screens for remaining applications.

I even tried restricting access to these two apps (docs and examples) using valve and filters. And unfortunately, again the same issue: I get blank screens.

Finally, I started with a clean installation. However, I get same result after undeploying docs and examples.

Permission is not an issue, all contents belong to the tomcat user.

I am using Tomcat 8.5.37.

Operating System: Amazon Linux 4.14.88
Java version: 1.8.0_191-b12