Bug 63529 - Add more unit tests for org.apache.jorphan.util.JOrphanUtils
Summary: Add more unit tests for org.apache.jorphan.util.JOrphanUtils
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.2
Assignee: JMeter issues mailing list
URL: https://github.com/apache/jmeter/pull...
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2019-06-26 09:51 UTC by John Bergqvist
Modified: 2019-07-10 18:30 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Bergqvist 2019-06-26 09:51:47 UTC
I've analysed your codebase and noticed that org.apache.jorphan.util.JOrphanUtils is not fully tested.

I've written some more tests for the methods in this class with the help of Diffblue Cover

Hopefully, these tests will help you detect any regressions caused by future code changes.
Comment 1 Philippe Mouawad 2019-07-10 18:30:07 UTC
This is an automated email from the ASF dual-hosted git repository.

pmouawad pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/jmeter.git


The following commit(s) were added to refs/heads/master by this push:
     new 05d3975  Add unit tests for org.apache.jorphan.util.JOrphanUtils (#472)
05d3975 is described below

commit 05d39754aa31e17e40d3425c2fefb65e39d1ef34
Author: John Bergqvist <31512273+JohnLBergqvist@users.noreply.github.com>
AuthorDate: Wed Jul 10 18:02:04 2019 +0100

    Add unit tests for org.apache.jorphan.util.JOrphanUtils (#472)

    These tests were written using Diffblue Cover
---
 .../org/apache/jorphan/util/TestJorphanUtils.java  | 45 ++++++++++++++++++++++
 1 file changed, 45 insertions(+)