Bug 63538 - Add JSR223 support to given specific jars (ClassLoader)
Summary: Add JSR223 support to given specific jars (ClassLoader)
Status: NEW
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: unspecified
Hardware: All All
: P2 enhancement with 1 vote (vote)
Target Milestone: JMETER_5.2
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-02 12:17 UTC by orimarko
Modified: 2019-07-02 12:17 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description orimarko 2019-07-02 12:17:23 UTC
When executing JSR223 script you sometimes need different/older version of jars (as apache commons)

Solution is to add an optional jars folder which will be used as ClassLoader when creating ScriptEngineManager in JSR223BeanInfoSupport

First asked in https://stackoverflow.com/questions/56842003/ways-to-resolve-library-conflict-in-jmeter