Bug 63594 - Added support for TLS1.3 protocol from apache benchmark utility
Summary: Added support for TLS1.3 protocol from apache benchmark utility
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: support (show other bugs)
Version: 2.4.39
Hardware: Other Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 63593 64699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-23 06:58 UTC by abhilash
Modified: 2021-02-28 12:39 UTC (History)
2 users (show)



Attachments
Patch to ab.c that enables TLS1.3 protocol support. (2.03 KB, patch)
2019-07-23 07:00 UTC, abhilash
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description abhilash 2019-07-23 06:58:43 UTC
Attached patch for TLS1.3 support.

Apply patch:
cd httpd-2.4.39/support;
patch -p0 < tls13_ab.patch

These protocols will be available through the same command line parameter [-f] as the other protocols. These changes will not affect the existent functionality.

 * -f TLS1.3 for using the TLS 1.3 protocol and provide TLS1.3 compatible cipher suite with -Z parameter.
 

OpenSSL 1.1.1 or higher is required. If not available, these protocols won't be available.
Comment 1 abhilash 2019-07-23 07:00:11 UTC
Created attachment 36674 [details]
Patch to ab.c that enables TLS1.3 protocol support.
Comment 2 abhilash 2019-07-23 07:01:56 UTC
*** Bug 63593 has been marked as a duplicate of this bug. ***
Comment 3 Christophe JAILLET 2021-02-28 12:39:23 UTC
*** Bug 64699 has been marked as a duplicate of this bug. ***