Bug 63619 - cannot rpmbuild - Installed (but unpackaged) file(s) found mod_socache_redis.so
Summary: cannot rpmbuild - Installed (but unpackaged) file(s) found mod_socache_redis.so
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.4.39
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-29 17:27 UTC by danie.dejager
Modified: 2019-09-24 17:49 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description danie.dejager 2019-07-29 17:27:57 UTC
Hi,

I read that this was supposed to be fixed in an earlier release in April 2019 but I'm still running into this where I cannot build the rpms:

rpmbuild -tb httpd-2.4.39.tar.gz


Processing files: mod_proxy_html-2.4.39-1.x86_64
Provides: mod_proxy_html.so()(64bit) mod_xml2enc.so()(64bit)
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libc.so.6(GLIBC_2.3)(64bit) libc.so.6(GLIBC_2.4)(64bit) libpthread.so.0()(64bit) libxml2.so.2()(64bit) libxml2.so.2(LIBXML2_2.4.30)(64bit) libxml2.so.2(LIBXML2_2.5.2)(64bit) libxml2.so.2(LIBXML2_2.6.0)(64bit) rtld(GNU_HASH)
Processing files: mod_ssl-2.4.39-1.x86_64
Provides: config(mod_ssl) = 1:2.4.39-1 mod_ssl.so()(64bit)
Requires(interp): /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(pre): httpd
Requires(post): /bin/cat /bin/sh openssl
Requires: libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libc.so.6(GLIBC_2.4)(64bit) libcrypt.so.1()(64bit) libcrypto.so.10()(64bit) libcrypto.so.10(OPENSSL_1.0.1)(64bit) libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) libcrypto.so.10(libcrypto.so.10)(64bit) libpthread.so.0()(64bit) librt.so.1()(64bit) libssl.so.10()(64bit) libssl.so.10(libssl.so.10)(64bit) libuuid.so.1()(64bit) rtld(GNU_HASH)
Processing files: httpd-debuginfo-2.4.39-1.x86_64
Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/rpmbuild/BUILDROOT/httpd-2.4.39-1.x86_64
error: Installed (but unpackaged) file(s) found:
   /usr/lib64/httpd/modules/mod_socache_redis.so


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib64/httpd/modules/mod_socache_redis.so
Comment 1 danie.dejager 2019-07-29 17:30:37 UTC
This made no difference:

Modified: httpd/httpd/branches/2.4.x/build/rpm/httpd.spec.in
URL: 
http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/build/rpm/httpd.spec.in?rev=1856868&r1=1856867&r2=1856868&view=diff
==============================================================================
--- httpd/httpd/branches/2.4.x/build/rpm/httpd.spec.in (original)
+++ httpd/httpd/branches/2.4.x/build/rpm/httpd.spec.in Wed Apr  3 
10:01:47 2019
@@ -392,6 +392,7 @@ rm -rf $RPM_BUILD_ROOT
  %{_libdir}/httpd/modules/mod_slotmem_shm.so
  %{_libdir}/httpd/modules/mod_socache_dbm.so
  %{_libdir}/httpd/modules/mod_socache_memcache.so
+%{_libdir}/httpd/modules/mod_socache_redis.so
  %{_libdir}/httpd/modules/mod_socache_shmcb.so
  %{_libdir}/httpd/modules/mod_speling.so
  %{_libdir}/httpd/modules/mod_status.so
Comment 2 Petros Marios Prokopiou 2019-09-20 10:57:46 UTC
Adding mod_socache_redis.so to %files fixed the issue after I replicated it

 %{_libdir}/httpd/modules/mod_mpm_prefork.so
 %{_libdir}/httpd/modules/mod_mpm_worker.so
+%{_libdir}/httpd/modules/mod_socache_redis.so

Used httpd-2.4.39.tar.gz and httpd-2.4.39.tar.bz2 from
http://www.apache.org/dist/httpd/?C=M;O=D

Sidenote: I had to comment out mod_mpm_event.so because it wasn't being installed, I didn't try to find out why.

It gave me the following error:
error: File not found: /home/pprokopi/rpmbuild/BUILDROOT/httpd-2.4.39-1.x86_64/usr/lib64/httpd/modules/mod_mpm_event.so

So I changed the line
-%{_libdir}/httpd/modules/mod_mpm_event.so
+#%{_libdir}/httpd/modules/mod_mpm_event.so

Besides that, no other changes were made to httpd.spec.

diff --git a/httpd.spec2 b/httpd.spec
index 903d36d..7c32378 100644
--- a/httpd.spec2
+++ b/httpd.spec
@@ -359,9 +359,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/httpd/modules/mod_macro.so
 %{_libdir}/httpd/modules/mod_mime_magic.so
 %{_libdir}/httpd/modules/mod_mime.so
-%{_libdir}/httpd/modules/mod_mpm_event.so
+#%{_libdir}/httpd/modules/mod_mpm_event.so
 %{_libdir}/httpd/modules/mod_mpm_prefork.so
 %{_libdir}/httpd/modules/mod_mpm_worker.so
+%{_libdir}/httpd/modules/mod_socache_redis.so
 %{_libdir}/httpd/modules/mod_negotiation.so
 %{_libdir}/httpd/modules/mod_proxy_ajp.so
 %{_libdir}/httpd/modules/mod_proxy_balancer.so

Could you share the %files part of your specfile ?
Comment 3 Christophe JAILLET 2019-09-21 04:56:46 UTC
(please do not set status to RESOLVED until a fix is committed, or clearly stated that nothing needs to be done. Based on comment #0 and comment #2, it looks that something has to be fixed)
Comment 4 Petros Marios Prokopiou 2019-09-23 08:08:05 UTC
(In reply to Christophe JAILLET from comment #3)
> (please do not set status to RESOLVED until a fix is committed, or clearly
> stated that nothing needs to be done. Based on comment #0 and comment #2, it
> looks that something has to be fixed)

The fix for this particular issue has already been applied.

http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/build/rpm/httpd.spec.in?view=diff&r1=1856867&r2=1856868&pathrev=1856868
Comment 5 Petros Marios Prokopiou 2019-09-23 08:13:07 UTC
In case you are referring to the line

+#%{_libdir}/httpd/modules/mod_mpm_event.so

in my previous comment, which is not addressed by the existing fix, I haven't confirmed if it's an actual issue.
If it is, perhaps I should open a separate ticket to track it ?
Comment 6 Christophe JAILLET 2019-09-24 17:49:53 UTC
Fixed in r1856868.

(In reply to Petros Marios Prokopiou from comment #5)
> In case you are referring to the line
> 
> +#%{_libdir}/httpd/modules/mod_mpm_event.so
> 
> in my previous comment, which is not addressed by the existing fix, I
> haven't confirmed if it's an actual issue.
> If it is, perhaps I should open a separate ticket to track it ?

Yes please.