Bug 63722 - JMeter master hangs distributed test even and the slaves have not finished running the remaining threads
Summary: JMeter master hangs distributed test even and the slaves have not finished r...
Status: RESOLVED DUPLICATE of bug 63723
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.1.1
Hardware: PC All
: P2 blocker (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-04 03:16 UTC by isuk
Modified: 2019-09-05 20:19 UTC (History)
1 user (show)



Attachments
Two slaves and Master outcome (149.71 KB, image/png)
2019-09-04 03:16 UTC, isuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description isuk 2019-09-04 03:16:12 UTC
Created attachment 36753 [details]
Two slaves and Master outcome

- I'm using Jmeter 5.1.1.
- I have set up a distributed load test environment using windows 10 machines (master/my local with two VMs running on the same subnet)
- Non-GUI mode is used.
- trying to run 1000 concurrent threads on the two VMs (500VU load each).
- JMeter-server batch files are opened on the two slaves/hosts.
- Jmeter command is executed to run the distributed load:-

Actual result:
- Both slaves have started the test (JVM) and running
- Both slaves keep running. Master runs the load for e.g. 973VUs and hangs. Rest Not sure what is happening for the rest 27 (tried this case many times still occurs-with different completed threads. E.g. 992VUs completed 8 remained. JMeter hangs it seems.

NOTE: Have increased the Java HEAP on Master and two slaves (min 2g to XMX 8g). So no memory resource issue at all either.

Have tried this scenario for a couple of days. Not able to finish the full 1000VU distributed test load.

NOTE: Marking this as a blocker - as it is a blocker for our work.
Comment 1 Philippe Mouawad 2019-09-05 20:19:28 UTC

*** This bug has been marked as a duplicate of bug 63723 ***