Bug 63789 - Summary Report Listener throws NullPointerException
Summary: Summary Report Listener throws NullPointerException
Status: RESOLVED DUPLICATE of bug 63433
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.1.1
Hardware: All All
: P2 normal (vote)
Target Milestone: JMETER_5.2
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-30 13:35 UTC by George Vrachliotis
Modified: 2019-10-08 20:03 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Vrachliotis 2019-09-30 13:35:07 UTC
During test execution, Summary Report listener throws - at random intervals - sample result errors of the following type:

2019-09-30 16:23:56,961 ERROR o.a.j.t.ListenerNotifier: Detected problem in Listener.
java.lang.NullPointerException: null
	at java.util.concurrent.ConcurrentHashMap.putVal(Unknown Source) ~[?:1.8.0_65]
	at java.util.concurrent.ConcurrentHashMap.put(Unknown Source) ~[?:1.8.0_65]
	at java.util.Collections$SetFromMap.add(Unknown Source) ~[?:1.8.0_65]
	at org.apache.jmeter.samplers.SampleResult.markFile(SampleResult.java:504) ~[ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.reporters.ResultCollector.isResultMarked(ResultCollector.java:582) ~[ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.reporters.ResultCollector.sampleOccurred(ResultCollector.java:549) ~[ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.threads.ListenerNotifier.notifyListeners(ListenerNotifier.java:70) [ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.threads.JMeterThread.notifyListeners(JMeterThread.java:980) [ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.threads.JMeterThread.executeSamplePackage(JMeterThread.java:569) [ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.threads.JMeterThread.processSampler(JMeterThread.java:486) [ApacheJMeter_core.jar:5.1.1 r1855137]
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:253) [ApacheJMeter_core.jar:5.1.1 r1855137]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_65]
2019-09-30 16:23:56,961 INFO o.a.j.t.ListenerNotifier: Continuing to process further listeners

As result, sample results with this error are not recorded in the results file. In a small 2 minute test, with 100 threads, ramp-up at 60 seconds and a single dummy sampler in the thread group, I get each time approx. 4-5 errors
Comment 1 Philippe Mouawad 2019-09-30 13:38:09 UTC
Hello,
Issue is already fixed in nightly build.
You can test it and confirm.
Thanks

*** This bug has been marked as a duplicate of bug 63433 ***
Comment 2 George Vrachliotis 2019-09-30 14:31:07 UTC
(In reply to Philippe Mouawad from comment #1)
> Hello,
> Issue is already fixed in nightly build.
> You can test it and confirm.
> Thanks
> 
> *** This bug has been marked as a duplicate of bug 63433 ***

Hi Phillipe,

thanks for your prompt response. It seems however that this is not the case, because filename in my test is never null. 

After several tests, I have found that the issue happens if the summary report filename contains a user defined variable in the filename string, e.g. results_${env}.jtl. Every test with this gets 4-5 errors in a 2 minute execution with 100 threads. If I enter a fixed value e.g. results_QA.jtl I never get an error.
Comment 3 George Vrachliotis 2019-09-30 15:37:16 UTC
Checked issue with Build #7417 and it seems that it works ok.
Comment 4 Philippe Mouawad 2019-10-08 20:03:02 UTC

*** This bug has been marked as a duplicate of bug 63433 ***